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SA is used in many high-profile applications throughout a wide array 
of industries, from manufacturing to science and research. Some of 
these industries include:

	■ Aerospace (aircraft and spacecraft)

	■ Shipbuilding

	■ Particle Accelerators

	■ Nuclear Energy

	■ Automotive

	■ Heavy Equipment

	■ Machining

You are about to embark on learning how to adeptly use the most 
powerful portable metrology software ever created. We think this 
learning period will prove to be remarkably short. Most users are able 
to confidently acquire and analyze data after only one day. In fact, it’s 
quite possible that you can start using SpatialAnalyzer simply by per-
forming a few trial and error “test drives”. The software is robust, and 
in general, it will politely inform you if you try something impossible.

We suggest that you may ultimately save time and grief by taking 
the time to read through this manual. Don’t be too particular about 
memorizing anything—after all, this document is available from 

CH
A

PT
ER

Congratulations on your purchase of SpatialAnalyz-
er, the world’s leading portable metrology software 
platform.  SpatialAnalyzer is a traceable, graphical 
metrology software package that can simultaneously 
communicate to virtually any number and type of di-
mensional measurement systems and perform com-
plex analysis tasks with ease.

1Welcome
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within SpatialAnalyzer. We hope you will obtain an understanding of 
the philosophy behind SpatialAnalyzer by reading this manual. If you 
are unable to read the manual, it also serves as an excellent reference 
when you have questions.

Above all else, the goal of our work has been to develop a software 
package where users of all levels of expertise may actually enjoy tak-
ing and analyzing measurements and may have confidence in the 
numbers they report.

About This Manual
New River Kinematics (NRK) regularly updates this manual to incor-
porate the most recent updates and changes to SA. However, due to 
the fact that this manual is currently under development, and due to 
the rapid pace of NRK’s software development, you may encounter 
out-of-date material. NRK is aware of this and is working to bring con-
tent up-to-date.

SpatialAnalyzer comes in several packages. In cases where it may be 
ambiguous, we try to make it clear if a capability is not available in a 
specific SA package.

If you have any comments or suggestions for this manual, or if you 
notice any errata, please report them to support@kinematics.com.

Conventions
A standard set of conventions have been established to help ensure 
that this document is easy to read. The established standards are de-
scribed here:

The titles of windows and dialogs will appear like this: Best Fit Trans-
formation.

Menu choices appear like this: Construct>Points>Enter.

Checkboxes, dropdowns, and other control choices appear like this: 
Show Scale Indicator in View.

Button titles appear like this: Apply.

Keyboard combinations appear like this: Ctrl+D.

Named fields or boxes that subdivide areas of the user interface will 
appear like this: Degrees of Freedom.

Filenames appear like this: License10734.met.

Text that you should type in will appear like this: Nominal.

New terms will look like this: Relationship Minimization.

Note:� An important note 
that accompanies the text 

appears in a box like this.

Warning:� A warning 
box, like this, will 
appear anytime there 

is information considered to 
be of a critical nature for 
either data integrity or 
measurement data accuracy. 
Failure to heed warnings 
could potentially lead to loss 
of data or incorrect results.

Tip:�  Tips or recommenda-
tions that include best 

practices or time-saving 
techniques will appear in a 
box like this.

mailto:support%40kinematics.com?subject=Support%20Question
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Hyperlinks or links to other locations in this document look like this: 
support@kinematics.com.

WARNING: UNITED STATES COPYRIGHT LAW PROTECTS THIS MANUAL, 
ASSOCIATED SOFTWARE, ALGORITHMS, AND VISUAL CONTENT.

A Closer Look
Additional information that is not critical, but may be of interest to curious readers, is 
printed in an box like this.
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Tutorial Index:
Spatial Analyzer Setup and Configuration:

“Installing Spatial Analyzer (SA)” on page 6

“Displaying Ribbon Menus” on page 6

“Customizing New SA Job Files” on page 7

Basic Operations

“Navigating the Graphical View” on page 8

“” on page 13

“” on page 20

The following tutorials are designed to guide you through various topics 
in SA and get you up and running as quickly as possible. They are specific 
topic based step by step guides to accomplishing specific tasks but as a 
whole they should help directly though the software and help to under-
stand the workflow and approach to operations within SA. 

For greater depth and theory consider one of our courses and contact 
training@kinematics.com for more details.

Basic Operations
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Installation and Configuration

Installing Spatial Analyzer (SA)

SA is a Windows only application. To run SA on a mac a windows com-
patibility environment must be run through Boot Camp or a similar 
application.

The current version of SA, as well as a beta testing version, can be 
downloaded from the kinematics.com webpage here:

https://kinematics.com/download/downloadindex.php

To install the application double click on the SpatialAnalyzer ####.exe 
file and follow the directions. 

Displaying Ribbon Menus
Starting in 2019 a ribbon menu was added to SA. This ribbon menu 
was designed to incorporate the best of the classic menus and the 
Toolkit menu and streamline SA workflow. The display of the ribbon 
menu is optional and enabled with a check box option on the Display 
tab of the Users Options “Show Ribbon Bar” (Figure 2-21):

Figure 2-1.  Default SA Window. 
The On/Off control for the Ribbon menu 
is found in the User Options on the 
Display Tab.

 The following tutorials will use the Ribbon menu display. Buttons 
within the tabs are referenced as [Tab Name]>[Section Name]>[Button 
Name]>[Sub Button Name]. So as an example, you can rename a 
point by going to the Home(the tab to select)>Point Editing (ribbon sec-
tion to look in)>Rename (the large icon). You can also rename many 
points using a naming patter by going one level deeper Home>Point 
Editing>Rename>Points using a Name Pattern , indicating to use the drop 
down button under Rename and select from within.
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Customizing New SA Job Files
Much of SA can be customized. Some basic settings are saved in the 
registry and will persist when SA is closed and reopened. However, 
much of the settings are saved within a job file. To customize how a 
new job file looks you can save a template by doing the following:

1.	 Configure a job file such that it has the settings you would like 
to see when SA opens.

2.	 Select File>Save as Read-Only SA Template (Figure 2-2) and 
save the file within the C:\Analyser Data\Templates directory 
as “default.xit64”. 

Figure 2-2.  Saving a Job File as a 
Read Only Template

Additional template files can be saved and opened as needed but the 
default template is used for newly created job files automatically. 
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Basic Operations

Navigating the Graphical View

Here is a summary of the mouse-clicks and keyboard shortcuts for 
navigating the graphical view (Figure 2-3). 

Figure 2-3.  KeyBoard Shortcuts for 
Graphical control

Navigating the Graphical View Tutorial

	■ Skill Level. Beginner.

	■ Description. In this tutorial, we will cover basic view control 
functions.

	■ Areas Covered. Hiding and Showing of objects, background 
color, panning, zooming and rotating.

	■ Time to Complete. Approximately 15 minutes.

Changing Render Settings
Here we will change the render mode for the SA graphics from wire-
frame to solid.

1.	 Open Query Points to Surface.xit from the Samples 
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directory under Help>Open Sample SA Files. When a file is opened, 
surfaces are by default rendered in wireframe mode in order 
to open the file as quickly as possible.

When a new file is opened, the CAD surfaces are displayed in wire-
frame mode by default. This avoids the wait that might be required if 
the surfaces were to be solid rendered in the view – something that 
could be a lengthy operation in a large, complex file.

2.	 The Render settings can be changed with the render mode 
icons available on the Home >Display section(Figure 2-4). 

Figure 2-4.  Render mode controls

Try each of the Render settings. Now render the model solid by using 
the Solid icon (Figure 2-5).  

	■ 	 Wireframe. Geometry is displayed as edges only, and hidden 
edges are visible. 

	■ 	 Hidden Line Removed. Geometry is displayed as edges only, 
but hidden edges are not displayed. 

	■ 	 Solid + Edges. Solid surfaces are rendered in addition to edg-
es. 

	■ 	 Solid. Solid surfaces are rendered without edges. 
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Figure 2-5.  Rendering in solid-
shaded mode.

Change Background Color
Let’s change the background color from a gradient to a solid color.

3.	 Access the background color options by using the Back-
ground button on the main toolbar also in the display section 

of the Home tab .

4.	 In the Background dialog (Figure 2-6), select the Solid color 
radio button. Now select a solid color by clicking the current 
solid color swatch. The color palette will display--choose a 
green color and press OK. Exit the background color dialog 
by pressing OK. After your eyes adjust...go back and change 
the background color to white by using the shortcut for white.
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Figure 2-6.  Changing the back-
ground color.

Hide and Show
Let’s experiment with the ways to hide and show points, objects, and 
other SA entities. In addition to the menu controls in the Visibility sec-
tion you can directly interact with the parts in the tree or the graphics:

5.	 Hide the vector group called Boat Error_Vectors_Blotches from 
the tree. Expand the Vector Group category in the tree. Now right-
click Boat Error_Vectors_Blotches and uncheck Show. The ob-
ject name will be greyed out in the tree (Figure 2-7). To show 
a hidden item, simply select Show again.  

Figure 2-7.  Hiding the vector 
group in the tree.
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TRANSLUCENCY
6.	 Right-click on the dish surface in the graphical view and select 

Translucency. Change the setting to Translucent and click OK.

Figure 2-8.  Changing CAD  translu-
cency so you can see through it.

Zoom, Pan and Rotate
Now that we can change colors, render, and hide/show objects, let’s 
learn how to manipulate the graphical view. See the Graphical View 
section for more information regarding Zoom, Pan and Rotate.

Zoom

1.	 Zoom in on the graphical view by placing your cursor over a 
zoom point of interest and rolling the scroll wheel forward on 
your mouse.

2.	 Zoom out by using the Page Down key.

3.	 Left-click in a region in which you’d like to zoom, drag a rect-
angle around that region, then release the cursor in the op-
posite corner to fit the zoom to your rectangle.

4.	 Now let’s put all visible objects back in the view by using Au-
toscale . You can also use the hot key (Alt+A).

Pan

5.	 Try panning by clicking and holding the center scroll wheel 
on the mouse. Then proceed to drag your mouse. If you don’t 
have a middle mouse button you can pan by holding down 
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the Shift key while pressing the left mouse button and 
dragging the mouse.

6.	 You can also use the arrow keys on the keyboard to pan the 
view up, down, left and right.

Rotating

7.	 Now let’s rotate the graphical view. Press and hold the right 
mouse button and drag the mouse. You will quickly notice 
that the view pivots about a particular point in space.

8.	 Let’s change the rotation center by selecting the View Rota-
tion Center button from the toolbar. Select one of the 
points at the corner of the model. Now rotate and you will see 
how the view pivots about the selected point.

Preset Views

Preset views are available which allow for quick orientation of the 
graphical view.

9.	 Press the drop down beside the  icon and select Top. This 
will orient the view with respect to the World frame. 

10.	 Saved presets can also be used. Now select the vector view 
preset view from the list.

Conclusion
We have now covered many ways to render objects, change back-
ground colors, show/hide objects and manipulate the graphics.
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Point  Properties and Data Management
Keywords

	■ Point Group. A group of points that share a commonality.  This 
could be a set of points that all define a specific feature, or all 
make up a group of fiducials. 

	■ Measured Point.  A point that was measured from an instru-
ment and will have all metadata associated with it. Measured 
points are automatically tied to an instrument and will move 
with it any time an instrument’s alignment is adjusted.

	■ Constructed Point.  A point that is created manually in a job 
file or a point that is imported.  

	■ Target Offset.  The amount that a point will needs to be shifted 
prior to checking its deviation from an object.  This is typically 
established when the point is measured via the instrument in-
terface. 

Opening a file to play with
1.	 In the Ribbon Bar, go to the HELP tab. In the Documentation 

section, choose  Documentatoin>Sample Files.

2.	 Open the SA file Best Fit Points To Points.xit. 

VIEW POINT PROPERTIES
3.	 Expand the Points Groups category in the tree to show Sta-

tion1 and Nominals point groups.

4.	 Now expand the Station1 and Nominals point groups to dis-
play the points in each. Take note of the icons for each point 
(Figure 2-9).  

Figure 2-9.  Measured vs. Con-
structed Points.
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(NOTE:  The red icons for the Station1 point group indicate they are 
measured points from an instrument.  The blue icons for the Nomi-
nals point group indicates they are constructed or imported points.)

5.	 Single left-click on the white triangle next to P1 located in the 
Station1 point group to see its X, Y, and Z values relative to the 
working frame.

6.	 Open the full target information for P1 by double-clicking it in 
the tree or graphically.  Right-clicking to open the properties 
is also an option (Figure 2-10). 

Figure 2-10.  Right-click to Open 
Point Properties

7.	 Select Measurement Details, to open the metadata for P1.  This 
will show you all the information that is attached to this point.

8.	 After reviewing select Done to close the dialog.

9.	 Notice at the bottom of the Target Information dialog there 
is a place where the planar and radial target offsets can be 
changed.  Select OK to exit the target information dialog. 

POINT MANAGEMENT
SA handles off sets by always recorded the center of the probe and 
recording the offsets as part of the point’s properties. This allows SA 
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to applying those offsets when a geometry fit or query is performed 
and use the direction vector of each point to object comparison to 
determine the exact off set direction. This ensures that the most ac-
curate offset is always used (Figure 2-11).

Figure 2-11.  Offsets Recorded 
with a Point

Both Planar and Radial offsets are saved in a points properties. The 
planar offset is the primary offset used for most everything. Anytime 
you measure a surface the query direction provides the “planar direc-
tion for comparison. Radial offsets are secondary, only being used as 
part of a geometry fit where such as in a pin-net measurements of a 
hole. In this case the circle can be fit first, in plane, and then the radius 
can be adjusted as needed (Figure 2-12).

These values are set automatically for you when you select the cor-
rect tooling in the instrument interface and measure from within SA, 
but they can easily be adjusted.
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Figure 2-12.  Planar and Radial 
Offsets

We noticed earlier that the point offset for P1 was 0.75” planar and 
radial.  Let’s change those point offsets to 1” for every point in the Sta-
tion1 point group.

10.	 Right-Click on the Station1 point group in the tree and select 
“Set Point Properties”. 

Figure 2-13.  Set Properties for 
Multiple Points at one time.

	■ A. Select the top checkbox to change the target offsets. 

	■ B. Type “1.0” in the textbox next to “Planar and Radial” to change 
the offsets to the desired value. 
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	■ C. Select second checkbox to apply the settings to the mea-
surements.

	■ D. Click OK to update the points.

11.	 Check the properties of any point in the Station1 point group 
to ensure the planar and radial offsets show 1”, respectively.  
Then Click Ok to close.

12.	 In the Ribbon Bar, select Group Manager.  This will show you 
every point group in the SA job file and its values.

13.	 Here we can rename multiple points simultaneously.  (Ensure 
to have the Station1 point group selected). Press Ctrl+H to 
bring up the “Replace” dialog.  

Figure 2-14.  Renaming Points 
Using Group Manager

	■ A. Type “P” in the search field. 

	■ B. Type “Nom_” in the replace field. 

	■ C. Click OK.

EXPORT/ IMPORT POINTS
14.	 Right-Click on the Nominals point group in the tree and select 

“View Point List”.
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15.	 In the next dialog click “Export to Text file”.

16.	 You will be prompted to select every point in the list shown, 
select “Yes”.

17.	 Next you will need to choose a location to save the exported 
point list.  Choose the desktop, the default file name will be 
“Point List.txt”, click Save.

18.	 In the next dialog, the Ascii Export dialog, you can change 
some of the export settings, but here we will select OK.

19.	 Finally, you will see your saved point list in notepad.  You can 
close this window and return to the job file.

20.	 Now, at the top left corner of the SA Job file, click on the file 
menu icon and follow the steps laid out in the below image to 
import the Ascii File. 

Figure 2-15.  Importing Points 
from an AScii Text file.

21.	 When prompted, select the file that you would like to import 
and choose the Point List.txt file that you previously saved to 
your desktop.

22.	 The Ascii Import window will open.  All the settings should be 
set correctly by default, so select Import at the bottom of the 
dialog.

23.	 An import report will open to notify you that 7 points were 
imported correctly.  Click OK. NOTE:  In the tree there should 
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now be another point group named Point List.txt and should 
include the 7 points that were exported.
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Coordinate Systems In SA
Overview of How to Control Coordinate Sys-
tems

Spatial Analyzer provides a lot of flexibility when it comes to defining 
a base coordinate for a job file. There are lots of terms for this in differ-
ent software packages including:

	■ Spatial Reference System

	■ Coordinate Reference Systems

	■ Coordinate Reference Frame

	■ Frame of Reference

	■ 6D location

SA uses the shortest and simplest term and calls a coordinate refer-
ence frame simply a “Frame”. Each job file has a base reference for the 
job file which is called the “WORLD” frame. Any time you open a new 
job file you will find that it already has a frame in it called “WORLD” 
which defines the base reference for the job file (Figure 2-16).

Figure 2-16.  The World Frame is 
the Base reference for the entire job file.

Also notice that this WORLD frame is marked in bold blue letters and 
labeled “(Working)”. That means that this frame is used to define the 
reported locations of anything else in the job file. So if you were to 
create a cylinder and wanted to report its location you are imme-
diately given its location in a Cartesian coordinate system with the 
WORLD frame defining the origin of this reference. 

Building a Cylinder at a specific location

1.	 To build a cylinder navigate to the Construction Tab and in 
the Build manually drop down select Cylinder.
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Figure 2-17.  Build a Cylinder by 
entering its coordinates.

2.	 The Properties of the newly created cylinder will pop up. To 
accept the default properties, select close at the bottom right 
of the window. 

In the example below the cylinder shown is 24” away in X and shifted 
9” away in Y and its origin is perfectly on the XY Plane with respect to 
the World Frame (Figure 2-18).

Figure 2-18.  Location of a cylinder 
in 3D space with respect to the World 
frame.

Changing the Working Frame
What is unique about SA is that at any time you can select any frame 
in the job file, right-click on it and select Make Working Frame and it 
becomes the working frame for the job. This changes the reporting 
of all objects in the job file to now report their location with respect 
to the new “Working Frame”. In the image below a new frame was 
added to the prior example file without editing the location of either 
the World frame or the Cylinder. Once the New Frame was marked as 
Working the cylinder’s coordinates were updated to reflect its posi-
tion relative to the New Frame.
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Figure 2-19.  Resulting change 
in location of a cylinder’s coordinates 
when a new frame is set as Working.

Its easy to tell which frame is the current working from because it 
is both clearly displayed in the graphics (only the working frame is 
drawn in 3D while the other frames in the job are shown as lines) and 
marked in the tree:

Figure 2-20.  The Working frame 
in the tree is marked in Bold.

Setting A Reporting Frame
There are times when its helpful to be able to report the location of an 
object with respect to a frame that is not the current working frame. 
This can also be done and is set within the object’s properties by edit-
ing the “Reporting” Frame. 

Frames can be created in many ways, including being directly mea-
sured from any 6D probing device, and define a location. Including 
reporting a position and rotation in space they can also be used for 
alignment.
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Working With Frames Tutorial
	■ Skill Level. Beginner.

	■ Description. In this tutorial, we will explore working with dif-
ferent coordinate frames, and see how the working coordinate 
frame affects the values reported in SpatialAnalyzer.

	■ Areas Covered. Creating points and geometry, geometry 
fitting, frame construction/activation, transformations, and 
point/object queries.

	■ Time to Complete. Approximately 30 minutes.

Creating Entities to Work With
For this tutorial, we want to create some points and geometry to play 
around with, so we’ll start out by creating those entities first.

3.	 In SA, start a new job file by selecting File>New from the menu 
or choosing the New File Icon from the Quick Access Toolbar.

 

4.	 Let’s create a few points to work with in the workspace. To 
do this, go to the Construction Tab and Press Build Manually 
press Ctrl+P.

5.	 In the Add Points to Model dialog (Figure 2-21), let’s place 
the points into a collection called Nominal and a point group 
called NominalPoints. We’ll give the first point a name of 1. 
Give the point an X coordinate of 15, a Y coordinate of 10, 
and a Z coordinate of 7.  We’re entering these coordinates as 
Cartesian (XYZ) coordinates, so we’ll leave that setting at the 
default:  
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Figure 2-21.  Adding a point.

6.	 Click the Add Point button, then click Done. In the graphical 
view, you should see a point created at the specified coordi-
nate. If you don’t see it, autoscale the view by clicking the Au-
toscale button in the Quick Access Toolbar , pressing 
Alt+A.

7.	 In the tree view, you should see that the Nominal collection 
now exists. Since it did not exist when you created the point, 
SA created this collection for you.

8.	 In the tree, (if necessary) click the disclosure triangle next to 
Nominal to expand the list of items in the Nominal collection. 
Note that there is an item in the list named Point Groups. SA 
sorts items in the tree based on their category. Expand the 
Point Groups category, and you’ll see that SA created the Nom-
inalPoints point group, because it did not already exist.

9.	 Expand the NominalPoints point group to show all points con-
tained within the point group, then click the triangle next to 
the single point to show the coordinate of the point named 
1. You should see the coordinates that you just entered (Fig-
ure 2-22).

Figure 2-22.  The newly-added 
point.
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10.	 The default collection in your SA file is currently ac-
tive, because it is depicted in bold blue font in the tree. 
Let’s activate our new Nominal collection. Right-click on the 
Nominal text in the tree and, from the context menu, choose 
Make Active Default Collection. Now, any geometry that you create 
will be placed into the active Nominal collection.

11.	 Now let’s create another point. SA saves a history of the 
most recently used commands so that you don’t have to 
select them from the menu again if you’re repeating a sin-
gle command several times. To use this history, hold down 
Ctrl+Shift+Tab. In the upper-left corner of the graphical 
view, a menu should appear showing your recent commands 
since you started SA, with the most recent command at the 
top (Figure 2-23). You can also access this control directly on 
the Home Tab

Figure 2-23.  The list of recent 
commands.

12.	 Choose the Construct>New Points>Build Manually button from the 
list. Notice that SA remembers the last collection and point 
group that was used for this command. Enter 2 for the point 
name, and give it a coordinate of (20, 20, 20). Click the Add 
Point button.

13.	 After clicking the button, notice that SA automatically incre-
ments the point name by one. This behavior is found com-
monly in different parts of SA, and is intended to save time 
from typing, since incrementing names by one is so com-
mon.  Change the coordinates to (5,5,5) and click the Add 
Point button again to create the third point, then click the 
Done button to close the dialog.

14.	 Now let’s create a plane to work with. From the menu, select 
Construct>Plane(s)>Enter. The Plane dialog will appear (see Fig-
ure 2-26 on page 27), allowing you to specify properties for 
the newly created plane.

15.	 Leave the plane’s name at the default of Plane, and click the 
Transform button. Locate the plane at (35, 0, 0) and assign it 
an Rx value of 90°. Click the Update button.

16.	 If necessary, autoscale or zoom out so you can see the newly-

Note:� The Autoscale key-
board shortcut of Alt+A will 

only work if the graphical view 
has the focus, by clicking once on 
it.
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created plane relative to the points.

17.	 With the plane in view, set the Rx value back to 0°, and change 
Ry to 90°. Again, hit the Update button to see the plane change 
orientation. Now, click the increment arrows next to the Ry 
field and notice how the plane is rotating around the active 
coordinate frame’s Y axis. We’ll set the Ry value to 160°. Click 
the Update button, then click the “X” in the corner of the Plane 
Position dialog to close the window.

Figure 2-24.  The Plane Position 
dialog.

18.	 In SA (as in mathematics), planes extend infinitely in two di-
mensions. So, the boundaries that are depicted in the graphi-
cal view are purely to give you an idea of the location and 
orientation of the plane--the actual plane is not bounded. 
Notice also that planes have an arrow drawn along their nor-
mal to indicate the direction of the plane. All geometry and 
surfaces have normal directions, which define the positive side of 
the geometry. All measurements with offsets in SA are always 
compensated relative to this positive side:  

Figure 2-25.  The positive side of a 
plane is indicated with an arrow.

19.	 The plane’s normal direction can be reversed to face the op-
posite direction. In the Plane dialog, click the Reverse button.  

Figure 2-26.  Selecting the option 
to draw a plane’s normal vector.
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Notice how the arrow flips to face the opposite direction. Turn 
off the plane’s arrow so that it’s no longer drawn in the graph-
ical view by deselecting the Draw checkbox in the Plane dialog 
(Figure 2-26). Close the dialog by clicking the Close button or 
the “X” in the corner of the window.

20.	 Finally, let’s create a circle to work with. This time, rather than 
creating a circle and specifying its position and orientation, 
let’s fit a circle to the three points that we created earlier. 
Orient your view so that you can see all three points. From 
the menus, choose Construct>Circle(s)>Fit to Points or press 
Ctrl+Alt+C. You will be prompted for the points that will 
define the circle fit. Hold down the Shift key, and click-drag 
to define a rectangle around the three points. In the bottom-
left corner of the SA window, you should see a message say-
ing “Picked 3 Points”. If you look in the treebar, the selected 
points will highlight bold and blue,  and they will change to 
a highlight color in the graphical view. Press Enter to accept 
the selection.

21.	 You will be presented with the Circle Fit dialog (Figure 2-27), 
which allows you to define the parameters and results of the 
fit operation. Since three points perfectly define a circle, our 
resulting circle will end up passing through all three points 
exactly. Notice that the Max and RMS errors are zero:

Figure 2-27.  The Circle Fit dialog.
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22.	 In the bottom-left corner of the Circle Fit dialog, press the Car-
dinal Pts button. SA will ask you for the name of the group in 
which you’d like to place the cardinal points. Enter Nominal-
Points and click OK. 

23.	 Press OK  again and the Circle dialog will appear. Give the 
circle a name of MyCircle. Notice the Draw checkbox again. Se-
lect it to see that circles have a normal direction as well, and 
notice that two points have been created from our circle fit: 
one on the circle’s center, and another along the normal of 
the circle. These are the Cardinal Points. Turn the Draw checkbox 
back off, and click the Close button.

In the next section, we’ll create some coordinate frames using a few 
different methods.

Creating Frames
Coordinate frames are crucial to many functions in SpatialAnalyzer 
and metrology in general. They define the locations and directions 
that are important to you or the features that you’re measuring. SA 
has a number of powerful ways to create coordinate frames to meet 
all of the needs you might encounter on a day-to-day basis.

1.	 In the graphical view, note that the World frame is currently 
the working frame. The working frame is rendered with col-
ored arrows representing each of the axis directions: red for X, 
green for Y, and blue for Z. In the tree, you will also notice that 
the working coordinate frame is rendered in a bold blue font.

2.	 Let’s create a new coordinate system, offset it from the cur-
rent World frame, and change its orientation. From the menu, 
choose Construct>Frame>Enter. Give the frame the name Offset 
Frame. This command creates a new coordinate frame with 
the same position and orientation as the working coordinate 
frame. We want to move our new frame. Click the Transform 
button to bring up the Frame Position dialog (Figure 2-28). 
Offset the frame by 10 units in X, Y, and Z, and also rotate the 
frame by +45° about the Z axis. Click the Update button to see 
the new frame move to the new position:
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Figure 2-28.  Creating a new 
frame.

3.	 Close the Frame Position and Frame dialogs, and verify for 
yourself visually that the new frame’s origin is located at (10, 
10, 10) in the active (World) frame’s coordinate system. Verify 
also that your constructed frame is rotated 45° about the ac-
tive coordinate frame’s Z-axis. Notice that SA uses the right-
hand rule. If the thumb of your right hand is pointed along 
the axis of rotation, then curling your thumbs from one of the 
remaining axes to the other will define the sense of positive 
rotation. Our newly-created frame is drawn as a set of 3 or-
thogonal lines. The thicker colored arrows are only drawn on 
the coordinate frame that is currently active.

4.	 Let’s activate our newly-created coordinate frame. Click on 
the A::World button in the WCF Toolbar (your button may 
look slightly different depending on the name of your default 
collection).  

5.	 From the Object Selection dialog, double-click the Offset 
Frame frame. The button’s title will immediately change to re-
flect the new working frame, and the new frame will be ren-
dered as active.

6.	 Now let’s construct a frame on our circle. Objects can have 
frames constructed on them. The specific behavior is depen-
dent on the type of object, but for a circle, the frame will be built 
with its origin on the center of the circle and its Z-axis along 
the circle’s normal. From the menu, select Construct>Frame>On 
an Object. When prompted for the object, double-click the My-
Circle circle. Name our new frame Frame On Circle and close 
the Frame dialog.

7.	 Finally,  let’s create a coordinate frame whose origin is at one 
of our circle points, whose X-axis points directly to the second, 
and whose Z axis clocks along the point defining the circle’s 
normal. From the menu, choose Construct>Frame>3 Points>Origin, 
X axis>Point on XZ Plane. For the origin point, double-click the 
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point in the tree named Nominal::NominalPoints::1. Note that 
SA uses a convention to denote the “complete location” of an 
entity. For objects, it includes the collection, followed by two 
colons, then the object name. For points, it includes the col-
lection, followedby two colons, followed by the group name, 
followed by two more colons, and finally followed by the 
point name.

8.	 Let’s pick the Point along X axis by clicking on it visually in the 
graphical view. We want to pick the Nominal::NominalPoints::2 
point, but how do we know which is which? From the menu, 
choose View>Show Point Labels (or press Alt+L). This will toggle 
on and off the display of labels for the points. Ensure that the 
Point along X axis prompt is still displayed, and in the graphi-
cal view, double-click the point labeled 2.

9.	 When prompted for the Point along XZ plane, double-click 
the Point on Normal point. In the Frame dialog, give the frame 
a name of Clocked Frame and close the dialog.

Activating Frames
When analysis values are reported by SpatialAnalyzer, they are almost 
always reported in the working coordinate frame, unless otherwise 
specified. For example, when you query two points to determine the 
distance between them, you will be presented with the magnitude of 
the distance (in the current units), which will remain the same regard-
less of the working frame. However, you’ll also get delta values along 
each active frame axis (dX, dY, dZ). In some cases, you can explicitly 
specify the frame to report results in, regardless of which frame is cur-
rently active.

1.	 With the Offset Frame frame still active, right-click on the 
NominalPoints point group and choose Expand All Entries from 
the context menu. You should now be able to view the X/Y/Z 
coordinates for all of the point group’s points (Figure 2-29).
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Figure 2-29.  Viewing the point 
coordinates.

2.	 In the tree, right-click on Clocked Frame and choose Make Work-
ing Frame from the context menu. Notice that the point coor-
dinates change immediately to reflect the new coordinate 
frame’s position and orientation.

3.	 Let’s look at the point coordinates further. Point 1 is located at 
(0, 0, 0) because we used it to define the origin of our working 
frame. Point 2 has Y and Z coordinates of 0 because the X axis 
points directly to it. Finally, the Point On Normal point has a 
Y coordinate of zero, since we defined the frame so that the 
point lies in the frame’s XZ plane.

4.	 Next, activate the Frame on Circle frame. The Center point is at 
the origin, and the Point on Normal point is along the Z axis. 
In the tree, right-click on MyCircle and choose Properties from 
the menu. In the Circle dialog, click the Transform button. 
Notice that the circle has position and orientation values of 
zero, since the active frame was created on the circle. (In other 
words, the frame was created at the circle’s internal object ori-
gin). Close both dialogs.

5.	 Now we’ll measure a few distances. From the menu, choose 
Query>Point to>Point (or press Ctrl+D). When prompted, dou-
ble-click the Center point for the 1st point and Point on Nor-
mal for the second. In the Query Results dialog, the two points 
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have dX and dY values of zero (since they both lie along the Z 
axis of the active frame). If you were paying close attention (or 
have a photographic memory), you’ll notice that the distance 
between the two points is the same as the circle radius.

6.	 This time, activate the Offset Frame frame and follow the in-
structions in the previous step to compare the two points 
again. This time, notice that the two points have nonzero dX, 
dY, and dZ values, since they do not lie along the direction of 
any of the active frame’s axes.

7.	 Let’s determine the distance of one of our points from our 
plane. From the menu, choose Query>Point to>Object. Double-
click Point on Normal for the point, and Plane as the plane. 
The Query Results dialog will display the distance of the point 
from the plane along the active frame’s X, Y, and Z axes.

Conclusion
In this tutorial, we saw ways to create different geometric entities 
such as points, circles, and planes. We also explored a few methods 
of frame construction, and saw how results reported from commands 
can be influenced by the working coordinate frame.
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Tutorial Index:

Instrument Connection and Operation

“Connecting an Instrument” on page 35

“Basic Tracker Operation Using the Instrument Toolbar” on page 36

Connecting an Instrument
Spatial Analyzer (SA) is a software designed for measurement applica-
tions. It provides a window into a 3D world where measured point 
locations can be viewed from different angles and comparisons can 
be made between where measurements are in space. These measure-
ments can be either imported or measured directly by an instrument. 

In order to connect an instrument in SA, navigate to the Instrument tab 
of the Ribbon menu and Press the Add button.

The following tutorials are designed to guide you through various topics 
in SA and get you up and running as quickly as possible. They are specific 
topic based step by step guides to accomplishing specific tasks but as a 
whole they should help directly though the software and help to under-
stand the workflow and approach to operations within SA. 

For greater depth and theory consider one of our courses and contact 
training@kinematics.com for more details.

Instrument 
Operations
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Figure 3-1.  Instrument Add 
Button.

When you add an instrument to SA it defines an instrument station 
placement in the application’s 3D world. Measurements from this in-
strument station are linked to this instrument model. 

If you have connected to an instrument before then more than likely 
all you have to do to connect to that instrument again is to press the 
Connect button. However, initial setup and configuration requires a 
few more steps depending on the instrument type for that reason we 
have a selection of quickstart guides which were designed to help 
connect a particular instrument. 

For connection information regarding a specific instrument refer to 
the appropriate chapter of the Instruments Manual.

Each chapter has an overview section regarding the type of instru-
ment and the common functions used by all the instruments of that 
type and at the end is a selection of mode specific quickstart guides 
with specifics on how to connect. 

For tutorials with specific instrument types see:

“Basic Tracker Operation Using the Instrument Toolbar” on page 36

Basic Tracker Operation Using the Instrument Toolbar

This tutorial walks through basic connection and operation using a 
Leica AT960 as an example. 

ADDING AN INSTRUMENT MODEL TO SA
1.	 Open a blank SA Job File. 

2.	 Go to the INSTRUMENT tab. In the INTERFACE section, select 

the add instrument icon,  .

3.	 The ADD INSTRUMENTS TO SA dialog will open.  Follow steps 
in Figure 3-2 below. 
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Figure 3-2.  Add Instrument 
Options.

 

	■ A. Select the All Instruments filter if it is not already selected.

	■ B. Single left-click the tracker you would like to add to the job 
file.  The Leica AT960 is selected here, but you can also make a 
selection from the or Faro or API sections as well.

	■ C.  Selection Options from below the instrument image.

4.	 When you select the Options button, as displayed in the figure 
above, the Add Instrument Options dialog will open.  Follow 
the steps in Figure 3-3 below.
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Figure 3-3.  Add Instrument 
Options.

	■ d. Select Quickset as the instrument stand.

	■ e. Ensure the Run Interface checkbox is UNCHECKED. 

	■ f.  Click OK. 

The instrument placement can be changed when necessary. The de-
faults will suffice for this exercise, though in real world use, this would 
just be a preliminary position prior to locating your instrument to a 
part or reference system.  The current selection will position our in-
strument relative to World Frame, 50 inches along the X axis.  So, our 
instrument’s position once added, will be X=50, Y=0, and Z=0.)

5.	 Select Add Instrument button to add the instrument model to 
the job file. 

CONNECTING TO AN INSTRUMENT
For this tutorial we will connect to a tracker in simulation mode, which 
does not require an actual instrument.

6.	 In the INSTRUMENT tab In the INTERFACE section, select the 

dropdown in the Connect icon,  .

7.	 Select Laser Trackers from the dropdown.  

8.	 In the Connect to SpatialAnalyzer dialog, select the tracker 
model you just added. Click OK.

Each tracker move will involve adding a new instrument model to the 
job file. These represent tracker station placements and you could 
have many within a single job file.

9.	 In the Tracker Connection dialog, uncheck the Connect to 
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Tracker checkbox.  This will ensure that our computer connects 
to the instrument in simulation mode.  When actually connect-
ing to your instrument you will want this box checked. If you 
were to connect to a live instrument, this dialog povides the 
ability to adjust the IP address and ping the instrument.

Figure 3-4.  Connect to Tracker 
Dialog.

10.	 Click Ok.

INSTRUMENT TOOLBAR
The instrument toolbar is a simplified instrument interface which al-
lows the user to name points, define tooling and initiate measure-
ments easily.  See image below for explanation (Figure 3-5).

Figure 3-5.  Instrument Toolbar 
Controls

	■ a. Beam Status indicator

	■ b. Steer Tracker Head control

	■ C. Tooling Quick-Select

	■ D. Target Name

	■ E. Measurement Profiles

	■ F. Alarms

	■ G. Checks/Utilities

	■ H. Battery Status	
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	■ I. Access button to the full instrument interface.

Depending on who might have last used the tracker, you may see 
the full instrument interface when you connect, because this status 
is saved. This full interface can be undocked from the SA such that it 
appears as a stand alone application (Figure 3-6). If so you will see it 
in the windows task bar as a reflector icon. To switch back to the In-
strument Toolbar use the button on the bottom right of the interface. 

Figure 3-6.  The Full Tracker Inter-
face shown as a separate application.

11.	 Click the red beam status icon.  It will turn green to emulate 
the action of locking on to a reflector.

12.	 Click in the target name box to edit the point name (Figure 
3-7). 
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Figure 3-7.  Instrument Interface 
Point Naming Control.

13.	 In the Instrument Interface Point Naming window make sure 
the collection letter is A, Group is Temp, and Target is P1.  Once 
you have entered that information click OK. (The + and – sym-
bols on the right side of the dialog allow you to increment or 
decrement the group and target names.)

14.	 In the Tooling Quick-select section, select the SMR 1.5” option.

15.	 Now, in the Measurement Profile section select the single 

point option  .  A point will be measured and the X,Y, and 
Z of that point will flash in the top left corner of the graphical 
view (HUD) along with the point name.

16.	 In the treebar you will see a new Point Groups category has 
been created.  Expand that category and see the new point 
group “Temp” has been created which includes point “P1”.

TOOLING DEFINITIONS
We can change the tooling quick selects so that they show the most 
frequent tools we use for easy access.  To change them we need to 
right-click on the icon in the tooling quick select section that we 
would like to change.  That same action will allow us to build new 
tooling definitions as well.

17.	 Right-click on the SMR 1.5” tooling definition in the instru-
ment toolbar.  Then select the drop-down to see the available 
tooling choices.  If you do not see what you are looking for 
you can define new target .  
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Figure 3-8.  Target Quick Select.

18.	  Select define new target and click OK.

19.	 The Reflectors and Targets Dialog will open.  We will define a 
few new tooling definitions.  See Figure 15-5.

The top-left table will show the manufacturer definitions which are 
those that come directly from the instrument.  The larger table at the 
bottom are the targets defined within SA that can be assigned as a 
quick-select and used during measurement acquisition.  
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Figure 3-9.  Building Targets within 
the Reflector/Targets Database

	■ A. Select the RRR 1.5in in the Manufacturer’s Definition section.

	■ B. Click Add:  From Selected Reflector.

	■ C. Click the three checkboxes shown.  This will create target 
definitions that includes a Pin Nest, Plane Nest, and Edge Nest.  
Ensure the offsets for each tooling coincide with the physical 
tooling that will be used. Click OK when done.

Notice that the three tooling definitions that were created are now 
in the large table at the bottom of the Reflectors and Targets Dialog.  
Check the probe radius, extra planar offset, and lateral offset to en-
sure the values reflect the offsets you are wanting to add.

Figure 3-10.  Newly Constructed 
Target Definitions.
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20.	 Click OK to exit the database.

MEASUREMENT PROFILES
When taking measurements, we have the choice of how we would 
like to acquire the points.  We can also change the behavior of the 
measurement profiles.  Below are the four most common measure-
ment profiles (Figure 3-11). 

	■ Single Point.  When pressed takes a single point measurement. 

	■ Stable Point. When pressed will start a mode that allows you 
to hold the SMR stable within a certain space for a certain 
amount of time and a measurement will be taken.  This allows 
us to take measurements without someone repeatedly hitting 
the measure button.

	■ Spatial Scan.  When pressed will start a mode that takes incre-
mental measurements as the SMR is moved a certain distance.  
This is a continuous measurement and can be very useful when 
taking a multitude of measurements very quickly on a part.

	■ Tooling Ball. Used when measuring tooling balls typically for 
alignment purposes.  This allows us to measure around the 
tooling ball to create a sphere, which in turn generates a center 
of that sphere which is the measured center that can be used 
for alignment.

Figure 3-11.  The 4 Basic Measure-
ment Modes in the Toolbar.

To change the parameters of these measurement profiles, just right-
click the icon and edit the parameters. For the single and stable point 
modes, there are three selections:

	■ Fast. This mode takes .5 second worth of samples. 

	■ Standard. This mode takes two seconds of samples. 

	■ Precise.  This mode takes five seconds of samples. 

What this means is that the Leica 960 operates at 1000 Hz; therefore it 
takes 500 samples during fast mode operation.
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The Red, Yellow, Green and Blue silhouettes represent a user defined 
measurement profile.  You can right-click either one of them, click a 
drop down, and choose from a variety of other predefined measure-
ment options.  When chosen they will  be assigned to that silhouette.

Utilities and Checks
The final icons in the toolbar is the alarm icon and Checks/Utilities.  
See below.

Figure 3-12.  Alarms Checks and 
Utilities Controls Available from the 
Toolbar.

21.	 Press the Alarms button and then check the Discrete Point RMS 
Monitor checkbox. You will now be notified in the graphics if a 
measured point exceeds the set threshold.
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Tutorial Index:
Basic Alignments

“Measure Nominal Points” on page 47

“Drift Check Verification and Re-Alignment” on page 53

“” on page 58

“Quick Align to CAD” on page 66

Measure Nominal Points
1.	 Open the SA file containing your reference points needed for 

alignment or import the points into an existing file. 

2.	 In the Ribbon Bar, go to the INSTRUMENT tab and follow the 
steps in (Figure 4-1):

The following tutorials are designed to guide you through various topics 
in SA and get you up and running as quickly as possible. They are specific 
topic based step by step guides to accomplishing specific tasks but as a 
whole they should help directly though the software and help to under-
stand the workflow and approach to operations within SA. 

For greater depth and theory consider one of our courses and contact 
training@kinematics.com for more details.

Instrument 
Operations
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Figure 4-1.  Add, connect, and 
locate an instrument.

Benefits

This process prevents the user from having to extract center points

1.	 Open the SA file containing your reference points needed for 
alignment or import the points into an existing file. 

2.	 In the Ribbon Bar, go to the INSTRUMENT tab and follow the 
steps in FIGURE x-1:

a. Select Add. 

b. Select Connect.  

c. Select Locate.

3.	 Choose Measure Nominal Points.

4.	 Select the Nominal Point Group. This is the previously estab-
lished reference group.

DIALOG SETTINGS
5.	 Check that your optional settings are correct for your job (re-

member that these settings will vary depending on the job) 
(Figure 4-2):
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Figure 4-2.  Locate Instrument by 
Measuring Nominals dialog.

a. Change the group name for the group to contain measured points 
and click Apply. 

b. Check the Vary Scale box if you would like to “float the scale” (See 
Temperature Compensation module for details).  

c. Check the Hold Level box to make sure that a leveled instrument 
stays parallel to the Z-axis. 

d. The Closest Point box is checked by default to ensure that after 
three points are measured and an initial locate is performed, points 
may be measured without selecting the row first and SA will auto-
matically give the deltas between its closest corresponding point. 

e. Change the Tolerance box to display the dMag in RED and assign 
a point as out of tolerance. Click Apply after changing the tolerance. 

RECORDING POINTS
6.	 If you are measuring out of order, then click on the row of the 

first point that you would like to measure. There are several 
options for taking measurements, as shown in (Figure 4-3):
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Figure 4-3.  Measuring in the 
Locate Instrument Measure Nominals 
dialog.

a. Measure Manually. When clicked, the selected target in the list is 
measured. If the target already exists, an additional observation is 
added. 

b. Point At. Points the instrument at the selected target and attempts 
to lock on. This applies only if the instrument supports pointing/tar-
get acquisition.

c. Delete. Deletes the selected target. 

d. Single Point. Attempts to point at, acquire, and measure the select-
ed target. 

e. Multiple Points. Attempts to consecutively point at, acquire, and 
measure all points in the list. 

COMPLETING THE ALIGNMENT
7.	 Once all of the points have been measured (or all points that 

can be seen), then check the MAX and RMS and ensure that 
the deviations are within tolerance. If so, then choose Fin-
ished-Locate Instrument (Figure 4-4). 
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Figure 4-4.  Checking RMS and 
Max magnitudes and locating the 
instrument.

a. RMS and Max statistics are displayed here. 

b. Finished – Locate Instrument locates the instrument to the nominal 
group. 

REPORTING THE ALIGNMENT
8.	 In the SA Treebar, expand the Events category and double-

click on the last item added. This will display your alignment 
results in the Report Bar (Figure 4-5).
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Figure 4-5.  Locate Measure 
Nominals Report Table.
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Drift Check Verification and Re-Alignment
A Drift Check is a crucial part of the measurement process since it 
gauges how much your instrument has moved relative to the part 
you are measuring. Without recorded drift checks, your data is unreli-
able.

Key Points

	■ 	 Ensure that you have at least three control points. 

	■ Perform drift checks frequently and on regular intervals. The 
frequency will need to increase the tighter the tolerances. 

	■ Get to know your instrument and your working environment 
to establish an expected threshold for a drift check. If you have 
an idea of how accurate your instrument is under your expect-
ed working conditions, it will become second nature to accept 
and continue or add a new instrument and re-align.

	■ All drift checks are stored in the EVENTS category in the treebar 
for traceability and reporting purposes.  

Getting Started
This tutorial is for a points based inspection and alignment.

1.	 Open a new SA file. 

2.	 Add and Connect your instrument. You will need the SA demo 
part for this exercise, but not the CAD model. 

SETTING UP DRIFT POINTS WHEN YOU ARE NOT ALIGNING TO A REFERENCE SYSTEM

In this exercise we are not aligning to the part, but simply measur-
ing some of the as-built conditions of the part. Therefore, we do not 
have a reference system to tie in to but we still need to measure some 
initial points to check drift throughout the inspection and at the end.

3.	 Select the Instrument Control bar, name the Group Reference 
Points and the Target 1 (Figure 4-6). 
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Figure 4-6.  Naming Reference 
Points

4.	 Measure the six points shown below in Figure 4-7, ensuring 
that the probe is as stable as possible. 

 

Figure 4-7.  Six reference points to 
be used as drift checks

Before beginning your inspection, you may want to ensure that your 
setup is stable, and the reference points were measured properly. We 
recommend that you check the deviation of each point in real time. 
There is no need to record these points since you have not begun the 
measurement process yet. 
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5.	 In the tree bar, right-click on the point group A::REFERENCE 
POINTS and select Add Watch Window. 

6.	 Place the probe in each hole and make sure the deviation is 
what you would expect. If it is not, delete this point group, 
correct your setup and begin again at step 3. 

7.	 Measure the three planes in FIGURE X*3 by following the 
steps below:

a.	 In the Features tab, type Plane 1 in the name box.

b.	 Check the box Repeat for Inspection.

c.	 Click  the Plane button.

d.	 Measure this plane. 

e.	 In the Inspection Bar, click Next.

f.	 Measure Plane 2 and click  Next.

g.	 Measure Plane 3.

 

Figure 4-8.  Three datum planes.

PERFORMING A DRIFT CHECK

The occurrence of a drift check during an inspection will vary. Many 
metrologists check drift at specific time intervals if their job will take a 
long time to complete. If your environment is temperature controlled 
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and very stable, you may choose to check a drift every hour. If you 
work in an unstable environment you may want to check a drift every 
ten minutes. If you measure a great number of points and you would 
like to immediately validate those, then checking a drift at varying 
time intervals may be ideal. Or perhaps a crane moved overhead, and 
you want to check stability. There is not a one-size-fits-all standard for 
checking drift in portable metrology.

8.	 In the Ribbon Bar, navigate to the Instrument tab, and select 
Drift Check in the Instrument Station Controls section. 

9.	 Select the A::REFERENCE POINTS point group as the Drift Point 
Reference Group.

10.	 Measure points 1-6. 

11.	 Look below to Figure 4-9 to find the RMS and MAX errors. The 
RMS error is ________. The MAX error is _______. For training 
purposes, let’s say that this drift is acceptable. 

 

Figure 4-9.  The Drift Check Dialog

12.	 Click Finished – Drift Acceptable in the bottom-left of the dia-
log. 

13.	 Measure the two circles in Figure 4-10 (below):
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Figure 4-10.  Measure two circles 
as shown.

WHEN A DRIFT CHECK FAILS

1.	 To simulate a loss of drift, move the part slightly. 

2.	 Repeat steps 8-10. 

3.	 The RMS Error is ________. The MAX error is _______.  These 
errors should be much higher than if a loss of drift occurred 
naturally over time or due to temperature change. 

Since we have lost stability, a new instrument must be added and 
aligned to the original reference points established by the first instru-
ment station. There is a way to perform these steps automatically by 
using the “bad” drift points. 

4.	 In the Drift Check dialog, select Add new Instrument: Trans-
form. 

5.	 The Locate Instrument by Measuring Nominals dialog will appear. 
This prevents you from having to re-measure your reference 
points again. 

6.	 If you are satisfied with the alignment, click Finished – Locate 
Instrument.
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You must now re-measure Circle 1 and Circle 2 since there is no way to 
prove that drift was lost after these features were measured. 

7.	 Right-click on Circle 1 and select Delete Associated Points. 

8.	 Click Yes to confirm deletion. 

9.	 Repeat step 20-21 for Circle 2. 

THE FINAL DRIFT CHECK

10.	 Right-click on the instrument in the graphical view and select 
Drift Check.

11.	 Select the point group A::DRIFT RE-LOCATE as the drift point 
reference group. 

12.	 Measure points 1-6.

13.	 Ensure that the drift is acceptable before clicking Finished – 
Drift Acceptable in the bottom-left of the dialog. 
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Using Best-Fit to Align Point Measurements
In this tutorial, we have a set of nominal points (fiducials), and we’ve 
measured those nominal points with a laser tracker. Our task here is to 
locate the instrument by fitting the measured points to the nominals.

We’ll start by opening a tutorial file included with your installation 
of SA. In SA, choose Help>Open Sample SA Files.  Choose the Best Fit 
Points to Points.xit file. This file contains a laser tracker which 
has measured a series of 7 points, each of which has a corresponding 
nominal point.

1.	

Figure 4-11.  Best Fit Points to 
Points Example file

Let’s locate our instrument to the nominal points. In the tree, 
right-click the tracker and choose Locate. From the Locate In-
strument dialog, choose Best Fit (Figure 4-12).  
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Figure 4-12.  Locating using Best 
Fit.

2.	 You will be prompted to select the Nominals Group. Click one 
of the nominal (fiducial) points in the graphical view. When 
you do, the prompt will ask for the Measured Group, and you 
should then click one of the measured points. 

The Best Fit alignment operates by fitting together points within 
two separate point groups by fitting together points with the same 
names. In this file the points are not named the same within the two 
point groups. As a result you will see the following dialog open (Fig-
ure 4-13):
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Figure 4-13.  Automatic rename 
option provided by the Best Fit align-
ment.

There are a number of ways to rename points for this type of align-
ment but this tool uses an advanced Inter-point distance calculation to 
identify the relative placement of points in the two groups and usu-
ally does a pretty good job of matching up the names. 

3.	 Press OK and accept the renaming of the Station1 points, and 
the Best Fit dialog should open. 

4.	 The default value of 0.1” (2.54 mm) works fine for our inter-
point distance match tolerance. We know that each of our 
measured points should be within 0.1” (2.54 mm) of our nom-
inals after a best-fit it performed, so all of the points within 
this threshold will be renamed. (Note that this function would 
probably not work if the nominal points were symmetrical. 
In that case, SA wouldn’t know how to orient the measured 
points, and the resulting points may not be named correctly).

5.	 You will be presented with the proposed name changes. Click 
Accept to make the changes. The Station1 point names now 
match the Nominals point names. We’re now set to do a points 
to points best fit.

6.	

Fitting the Points

1.	 We saw how to use best fit from the instrument’s Locate 
menu. Let’s look at how to do it from the main menu. Choose 
Instrument>Locate (Transform to Part)>Best Fit.   As before, pick 
Nominals for the nominal group and Station1 for the mea-
sured group. The Best-Fit Transformation dialog will appear 
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(Figure 4-14). At the top of this window, we’re allowing 6 de-
grees of freedom for the fit: X, Y, Z, Rx, Ry, and Rz, which is what 
we want in this case. Notice the table at the bottom, which is 
currently displaying the nominal coordinates and resulting 
deltas. Click the Actuals checkbox to display the coordinates of 
the measured points. Notice that the fit hasn’t yet been per-
formed, and as a result the deltas are quite large. That’s why 
the Re-fit button (with the two chasing arrows) and the fit re-
sults are highlighted blue.

Figure 4-14.  The Best-Fit Transfor-
mation dialog.

2.	 Click the Re-fit button to calculate the fit. Immediately, the 
results of the fit are displayed (Figure 4-15).



63

CHAPTER 4 ■ Instrument Operations

Figure 4-15.  The fit results.

3.	 Notice that each field is color-coded based on the Toler-
ance Coloring Zones in the dialog.  Deltas between 0.0000-
0.0200” are not colored, deltas from 0.0200-0.0400” are yel-
low, 0.0400-0.0600” are blue, and 0.0600” and greater are 
red. Looking at the results of the fit, point M3 has a very 
large dX value relative to the other points. This is highlight-
ed by the red coloring. Click the “dX” column header twice 
to sort the values, with the highest value in the top row. 
 
It looks like our M3 point has a significantly higher dX error 
than the other points, so that point is suspect. Let’s temporar-
ily remove it from the fit to see how the solution is affected. 
Uncheck the checkbox in the Name column for point M3. Since 
this changes the fit, you again need to click the Re-fit button.

4.	 Immediately, the errors drop dramatically, which backs up our 
theory that the M3 point is not good. Let’s give our tolerance 
warning indicators smaller values, for good measure. Click the 
ellipsis button in the Tolerance Coloring Zones section of the dialog. 
In the Tolerance Zone Coloring dialog (Figure 4-16), set the 
values to 0.005”, 0.010”, and 0.020” respectively.
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Figure 4-16.  The Tolerance Zone 
Coloring dialog.

5.	 After the change, none of the rows are highlighted, so we 
know that all errors are within 0.005”. In fact, we can easily see 
that the largest error is just under 0.002”.

6.	 Now take a look at each of the individual components. The larg-
est dX error is 0.0006”, which we deem to be acceptable. The 
largest dZ error is 0.0004”, which is also acceptable. But notice 
that two of the dY errors are -0.0011” and 0.0016”.  These are 
at least double the largest errors of any of the other compo-
nents. Suppose that we believe that the Y values  from those 
two points might be unreliable. The best-fit dialog allows us 
to weight these individual components to zero, so that they 
do not affect the fit. Let’s do that now, starting with the point 
with the larger error.

7.	 Check the Weights checkbox so that we can see the individual 
component weights being applied. Double-click the M2 row. 
In the Best-Fit Item dialog (Figure 4-17), click the 0 button un-
der the Y component to set its component weight to zero and 
click the OK button.

Figure 4-17.  The Best-Fit Item 
dialog.

8.	 Click the Re-fit button.  (Note that it’s usually best to make 
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small changes and re-fit, so you can gradually see how the 
changes affect the solution). Now that the new solution is cal-
culated, the new largest dY is under 0.001”, so we may con-
sider this to be acceptable.

9.	 Click the Apply Transformation button. The instrument immediately 
snaps to the nominals (Figure 4-18). We’ve now performed a 
fairly complicated fitting operation with ease. We’ve removed 
a point from the fit operation, and weighted an individual 
component from another point to zero to exclude it from the 
fit. As a result, we brought our errors from over 0.030” to un-
der 0.001”. Since most of the points and components are still 
in the fit, we can still be confident that the fit is good.

Figure 4-18.  After the best fit.

Reviewing the Fit

1.	 Let’s review the results of our fit. When the fit was completed, 
an event was created in the tree called Best Fit Transformation. 
Turn on the Report Bar by selecting Reports>Report Bar Visible 
from the menus (if necessary), and click the event in the tree 
to select it.

2.	 In the Report Bar, notice that you can view all of the results 
from the fit, including the points and components that were 
excluded from the fit or assigned special weights.
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Quick Align to CAD
Quick Align is a tool used to align a measurement device to a nominal 
CAD model. Like its name suggests, it is a fast, easy process. However, 
some caution should be taken when selecting the points used in the 
Quick Align. A small error in measured data can have a large effect on 
the final alignment. For this reason, this section will deal with how to 
best select points on the CAD model for Quick Align.

First lets import a CAD model to work with

1.	 Open a new SA file.  

2.	 In the Quick Access toolbar select Auto Import and navigate 
to the SA DEMOPART_inches.CATPart within the samles 
directory (C:\Program Files (x86)\New River Kinematics\Spati-
alAnalyzer 2020.04.09_65432\Samples) (Figure 4-19).

Figure 4-19.  Importing CAD with 
the Auto Import Button

3.	 In the Choose CAD Features dialog, first uncheck the top box 
to de-select all items. Then, check the two boxes in the sur-
faces category as shown (Figure 4-20). This will exclude all the 
additional model details which we won’t be needing for this 
exercise.
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Figure 4-20.  Select Surfaces to 
Import

4.	 In the home tab in the view controls section, use the drop-
down arrow next to the surface rendering command (Figure 
4-21).

Figure 4-21.  Setting the Render 
Mode to Solid with Edges

Your model should now appear as follows(Figure 4-22):

Figure 4-22.  Imported NRK Part
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Next Add an Instrument and Connect

More details on that process can be found here “Measure Nominal 
Points” on page 47. 

Now we can Align using Quick Align

1.	 From the Alignment tab, choose Quick Align (Figure 4-23). Or 
simply right-click on the instrument you want align and select 
Locate>Quick Align to CAD.

Figure 4-23.  Quick Align to CAD 
button in the Ribbon Menu

When choosing points for the next dialogue, it is important to re-
member that these points must fully constrain your model. This is 
easy to envision for a model that has several flat and perpendicular 
sides, but can be more challenging for models with an organic shape. 
You should still think of this type of alignment as a 3-2-1 alignment. 
First, pick three points on the primary interface. Next, pick two points 
on the secondary interface, and finally at least one point on the ter-
tiary interface of the CAD model. You can think of this as a plane, line, 
point alignment.

Another important factor to consider when choosing the alignment 
points is whether your instrument will be able to measure those 
points in its current physical location to the part. For a laser tracker, 
you should consider line of sight restrictions, and for a portable CMM 
arm, you should consider the reach of the instrument to ensure that 
all points you select on the surface will be able to be measured. If 
there are features or surfaces of the part which are critical, adjust the 
location or orientation of your instrument to ensure that those can be 
measured.

The minimum points required for a quick align is 6 points. Again this is 
related to the 3-2-1 method of alignment. However, there is NO max-
imum number of points. The more points you choose in the align-
ment, the more confidence you will have in the alignment accuracy. 

2.	 When prompted, pick 3 points on the top surface of the base 
model (to define a plane), then two points on the front of the 
Vertical face (forming a line), and finally a point on the left 
side (Figure 4-24).
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Figure 4-24.  Quick Align Points

In this exercise, these are the points chosen. Note how they complete-
ly constrain translation in X, Y, and Z as well as rotation in Rx, Ry, and 
Rz. The order of selection is also shown. The points don’t necessarily 
have to be measured in any particular order, but, from an inspector’s 
standpoint, it helps to group the points together by area because the 
points must be measured in the order selected. 

3.	 The next step is to directly measure these points on your cad 
model. If you have already measured these points you can 
also pick the measurements associated with each alignment 
point (Figure 4-25).

Figure 4-25.  Picking Measure-
ments that have already been taken as 
an alternative to direct measurement

In this case, instead of measuring the points, select the ‘Pick Measure-
ment’ button and click on the inspection points in order. The points 
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are in order from p0 to p5. Choose each one in order by double click-
ing on them in the tree or single clicking on them in the graphics 
window.

4.	 You should see the results below (Figure 4-26). Choose Accept 
to confirm alignment

Figure 4-26.  Quick Align results 
showing a perfect fit with 6 points, the 
minimum for a 3-2-1 alignment.
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Feature Inspection 
Geometry Construction verses GR-Features

SA uses Geometry Relationships (GR-Features) to effectively link 
nominal and measured geometry with the measured points creat-
ing dynamic geometry ready to report.  These features can be built 
in advance or after measurements are made and, once built, provide 
a template for future measurements.  Static geometry construction 
is still an option but has generally been replaced by feature based 
measurement.

Why GR-Features verses GD&T
Geometry can also be inspected using our ASME and ISO compliant 
Standardized GD&T inspection process either separately or in combi-
nation with feature measurement. The primary reason these evalua-
tion processes are separate in SA are: 

1.	 Standardized GD&T feature checks use a built in datum align-
ment behind the scenes for each check. GR-Features display 
deviations using the current job alignment. What you see is 
what you get which lends its self to greater clarity. 

The following tutorials are designed to guide you through various topics 
in SA and get you up and running as quickly as possible. They are specific 
topic based step by step guides to accomplishing specific tasks but as a 
whole they should help directly though the software and help to under-
stand the workflow and approach to operations within SA. 

For greater depth and theory consider one of our courses and contact 
training@kinematics.com for more details.

Feature Inspection
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2.	 GD&T feature use standardized inspection processes that are 
designed to establish if a part is within specification. It as-
sumes measurements are perfect any deviations are reflec-
tions of the part. This makes the results more dependant on 
outliers in the data set. GR-Features use an RMS fit to help 
identify measurement error.  

As a general rule of thumb start with GR-Features which help identify 
measurement errors and are more flexible. Then move to GD&T in-
spection for part inspection following a standard protocol. 

Workflow Reference Guide:
The following reference for inspection are available:

	■ “How to Measure Features (Auto Detect) Using a Probing De-
vice.” on page 72

	■ “Building Geometry from Existing Measurements.” on page 
75

	■ “Building Center Points and Intersections from Existing Geom-
etry.” on page 77

How to Measure Features (Auto Detect) Using a Probing Device.

SA can automatically detect what feature type you are measuring us-
ing the points you measure. To begin:

1.	 Connect your instrument.

2.	 Navigate to the Features Tab of the Ribbon, enter a name for 
your new feature and then add an Auto Detect Feature (Figure 
5-1). 

Figure 5-1.  Auto Detect Feature

When you add the Aut Detect feature to the job, trapping will begin like 
this (Figure 5-2). You will see trapping indicated both in the SA Tree 
bar and in a popup Inspection Bar, which also gives you navigation 
controls. Settings for this behavior are on the Home tab of the ribbon 
under Inspection Options. 
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Figure 5-2.  Trapping has begun

3.	 When trapping is active measurements will be captured and 
used by the selected feature. When you have measured all the 

points you want for this feature press the next button 

When you press next SA will cycle through the available fit options 
and settle on the simplest feature it can find that fits with an RMS 
(root mean squared deviation) under the Auto Fit Tolerance you have 
set in the Auto Detect feature settings(Figure 5-3). 

Figure 5-3.  AutoDetect feature 
Settings

A new placeholder feature will also be added for you so that you can 
continue to measure (Figure 5-4). An audible beep will sound when 
this new feature has been added and is ready to be measured (which 
can be helpful when the screen is hard to see). 
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Figure 5-4.  Measuring the next 
feature

Continue to measure pressing Next after each feature has been mea-
sured. 

Troubleshooting/Additional Details
If you measure a plane with the Auto Reset Projection Plane option en-
abled (Figure 5-3) then the newly measured plane will become the 
active projection plane. This can be seen in the Features Tab and can 
be adjusted from there if need be (Figure 5-5).

Figure 5-5.  Projection Plane 
Control

Should the Auto Detect Feature fail to resolve a fit within the RMS 
tolerance you have set it can be manually assigned through the right-
click menu(Figure 5-6).
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Figure 5-6.  Assigning the Feature 
type within an Auto Detect Feature

Alternatively if a solution was found but it was not the desired geom-
etry then the newly built geometry’s type can be changed through its 
right-click menu . 

Figure 5-7.  Correcting the geom-
etry type.

Building Geometry from Existing Measurements.

1.	 Navigate to the Features Tab of the Ribbon and enter a name 
for your new feature in the Feature Name entry field.

2.	 Choose a selection mode (points, or groups) from the drop 
down list(Figure 5-8).

Figure 5-8.  Preparing to build a 
feature

If you would like to build a 2D feature like a circle or slot projected 
to a plane, the projection plane should also be set (this is not neces-
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sary when building geometry like planes and cylinders). A projection 
plane can be selected from the drop down list under the feature name 
field, if it already exists, or you can build a new one first by selecting 
that option from the Plane’s drop down list(Figure 5-9). 

Figure 5-9.  Prepare Projection 
Plane

3.	 Select a feature type to build. This new feature will take the 
name you enter and then prompt you to select. You can select 
a feature type directly or use the Auto-Detect feature to have 
SA figure out a desired feature type (Figure 5-10).

Figure 5-10.  Features list you can 
build

SA expects you to define the feature you want to build before you 
begin selecting anything. When you add the feature by clicking the 
desired feature button, a feature of the type you select will be added 
to the tree using the name you entered. It will then prompt you to se-
lect either Individual Points or Point Groups (all the points in a group) 
based upon your selection in the drop down (Figure 5-8). 

Selection can be performed in multiple ways:

	■ You can single click on items in the graphics

	■ You can hold down the Shift key + Left click and hold with the 
mouse button to drag a dotted rectangle around the items you 
want to select. 

	■ You can also select items in the Tree Bar Select Items panel.  

Troubleshooting/Additional Details
If you forget to enter a name, the feature can be renamed through its 
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properties. These can be accessed by double clicking on it the tree or 
right-clicking and selecting properties. Then the Rename button. 

If you forget to set the Data Association drop down menu the feature 
will be created but you will not be prompted to select anything. To fix 
this you can right-click on the placeholder geometry and select Associ-
ate Data (Figure 5-11).

Figure 5-11.  Direct Data Associa-
tion.

Building Center Points and Intersections from Existing Geometry.

Lets say you have a patter of 4 holes you have already measured. You 
would now like to fit geometry, build the center points from each 
hole, and determine the diameter of a circle fit through those center 
points (Figure 5-12). The following are the steps to do so:

  and define the diameter of a circle fit through them. 

Figure 5-12.  Pattern of circle with 
a circle fit through the center points.

1.	 Build a projection plane. Circles and slots are typically mea-
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sured by placing a probe inside the hole and measuring the 
wall of the feature. Therefore the first step is to build a projec-
tion plane that will define the plane for the circles. To do so, 
first enter a feature name, select the data to use, and add a 
feature like this: 

Figure 5-13.  Steps to build a 
projection plane

2.	 Now you can build circle by editing the name and then select-
ing the circle icon, and then selecting the points to use in the 
circle fit. 

Don’t be surprised if you fit a circle as a pin rather than a hole, we can  
fix that later. As you can see below, the circle is projected to the plane 
and fit as a pin inside the measured points, compensating automati-
cally for the point offsets (Figure 5-14).

correct this later. 

Figure 5-14.  First circle

3.	 Go ahead and build 3 more holes.

4.	 Open the properties of one of the circles and fix the geometry 
fit settings, such that the points define a hole measurement 
(Figure 5-15).
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Figure 5-15.  Changing the Geom-
etry fit settings from pin to hole

5.	 Turn on the Cardinal Points. The circle center points are included 
as part of the cardinal points. To turn them on first edit the 
settings as desired (in this case you probably want to turn off 
the point on normal) and then check the box to turn them 
on(Figure 5-16). 

Figure 5-16.  Enable the center 
cardinal point

6.	 Apply your settings to the other circles. As soon as you make 
changes to a circle you will see the graphics update accord-
ingly. You can apply your settings to other circles using the 
Apply to Selected Relationships Button (Figure 5-17). 
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Figure 5-17.  Applying your set-
tings to the other circles.

You will see a fairly complicated dialog offering you the ability to se-
lect only particular settings to apply, but just select all and your set-
tings will be applied to the other circles (Figure 5-18).

Figure 5-18.  Final fit circles.

7.	 Build an additional circle through the existing circle centers. 
This can be done by selecting the center points but there is 
an easier option. Select From Multiple Circle from within the cir-
cle drop down list. Geometry intersections of all types can be 
found in these feature drop down lists (Figure 5-19).
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Figure 5-19.  Selecting Circle from 
Multiple Circles

8.	 When prompted, select all 4 circles. 

Note that from the tree you cannot select the GR-Feature under the 
relationship category directly, but you can expand it to select the 
measured circle within. GR-Features tie together all the contributing 
pieces so that you can easily build reports(Figure 5-20).

Figure 5-20.  Selecting the mea-
sured circle within the GR-Circle Feature

9.	 Finally, add a diameter dimension to the circle you just cre-
ated by navigating to the Reporting tab and selecting the di-
ameter dimension from the dropdown list
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Figure 5-21.  Adding a diameter dimension to the circle from multiple circles

How to build a coordinate system using measured features

Taking the prior example, lets build a new coordinate frame from the 
projection plane and this circle patter (Figure 5-22). 

Figure 5-22.  Coordinate Frame 
built from a bolt hole pattern

To do so, do the following:
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1.	  Switch to the Features Tab of the ribbon, enter a name for this 
new frame and then press the Frame button like this (Figure 
5-23).

Figure 5-23.  Adding a frame. 

Frame are defined based upon a 3 inputs which can be entered in any 
order: 

	■ Origin. This defines the base coordinate of the frame

	■ Primary Axis. This axis is help perfectly to the selected refer-
ence

	■ Secondary Axis. This axis is fit as well as is possible to the refer-
ence while maintaining the primary axis alignment.  

2.	 Lets pick the origin first. In this case, we want to build a frame 
centered on the circle through the patter, or the center of the 
patter. To do so use the Select Object button and select this 
circle as the Origin like this(Figure 5-24).

Figure 5-24.  Selecting center circle as the reference for the new frame.

3.	 Next lets define the Primary Axis. In this case everything is be-
ing projected to the same plane, so lets use that. To do so se-
lect Object and select the projection plane. 

With each new selection the wire frame placeholder frame will up-
date give you a preview of the frame you are creating(Figure 5-25). 
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Figure 5-25.  Origin and Primary Axis selection 

If you notice, the definition for each axis can be changed. The primary 
axis is +Z by default but it can be edited as desired(Figure 5-26)

Figure 5-26.  Axis definition

4.	 Finally we want to clock the frame such that the secondary 
axis points from the center point of the first circle to the 4th 
circle. Select the 2 Points button and select the circle points in 
the order you want them to be used. 

If you are defining the +X axis for example select the first point as the 
start and the second point as the direction from that starting point. 

5.	 Accept the frame and pick a nominal reference frame if you 
wish. Doing so will provide a comparison between the frame 
for reporting purposes. 
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How to measure a set of reference points.

Another common measurement task is to measure a set of reference 
points using a probing device. This could be any set of defined point 
coordinates exported from another file or saved in a text file. 

To begin lets import a set of points from an ascii file. 

1.	 Drag and drop an ascii file with your nominal points into SA. 

Figure 5-27.  Importing a file into 
SA using drag and drop.

This can be any *.txt file with a standard format such as Point Name, 
X,Y,Z format. When you import it, our Ascii import dialog will open 
and you can choose the format that matches your file (Figure 5-28).
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Figure 5-28.  Ascii Import

2.	 Select the Points option for what you are importing, the for-
mat your file is in from the list of formats, and double check 
the collection and group names as to where you want the 
data to be stored.

3.	 Navigate to the Features tab of the ribbon and build a Group 
to Nominal Group relationship from this new point group(Figure 
5-29).

Figure 5-29.  Build a Group to 
Nominal Group relationship
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This will build a relationship or dynamic link between the imported 
created group you selected and a new placeholder group that is 
ready to be measured.

4.	 Double click on the relationship in the tree to open its proper-
ties, and select the options you would like to use, closing the 
properties dialog when satisfied.

Group to Nominal Group relationships offer a set of options which 
can be enabled while you measure for greater user feedback. These 
are optional and include: 

	■ Use closest point to match new measurements. This option 
is on by default and will rename the measured points to match 
the nominal points based on proximity

	■ Display closest point watch window. A watch window will 
open when you start trapping that shows the distance to the 
closest point. 

	■ Use view zooming and proximity. This option enables the 
view tracking and zooming as you get closer to the reference 
point. 

	■ Ignore points beyond threshold. This option prevents you 
from measuring if you are further than the preset distance 
from the reference point. 

	■ Update a vector group with relationship. This option creates 
auto-vectors to show you how far off your measurements are 
from the reference after you have taken the measurement.

5.	 Verify your instrument is connected and ready to measure.

6.	  Right-click on the relationship in the tree and select Trap Mea-
surements from an Instrument (Figure 5-30).



88

SPATIALANALYZER USER MANUAL

Figure 5-30.  Start Trapping

7.	 Measure the first 3 points from the list to locate the instru-
ment. If you are roughly aligned and measure the points in 
the same order as the reference group then you can continue 
measuring. But if not, 
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Tutorial Index:

Feature Inspection

“Creating Features from Existing Points” on page 89.

“Fitting Geometry from Points” on page 96.

“Geometry Relationships” on page 101.

“Contoured Surface Alignment and Evaluation with Relationships” on 
page 107.

Creating Features from Existing Points
This tutorial is set up to be a broad overview of Feature construction 
possibilities using the Features tab of the Ribbon menu. 

To begin by opening a sample file to work with. 

1.	 In the Ribbon Bar, go to the HELP tab. In the Documentation sec-
tion, choose Sample Files. 

2.	 Open the SA file GD&T with Multigage.xit. 

3.	 Go to the HOME tab. In the View Controls section, select the  
Solid   render mode.

4.	 Go to the Visibility section and select  Hide Selected Items, 
selecting all the Annotations. We will be inspecting without 
GD&T today.

5.	 Next, go to the FEATURES tab. 

CREATING FEATURES WITH EXISTING POINTS

6.	 In the New Feature Controls section.

7.	 In the white box type “Datum A”, which will be the name of 
the created feature.

8.	 Change the Data Association, by selecting  , then choosing  
.

9.	 Select   , then select the Datum A point group which will 
result in the creation of a plane.

10.	 Press Enter to confirm your selection. Our graphical view 
should look like (Figure 5-31). 
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Figure 5-31.  Plane Feature 
Creation.

11.	 Return to the Ribbon Bar and in the white box and type “Large 
BH”.

12.	 Select  , then select the Large BH point group which will 
result in the creation of a cylinder.

CHECKING FIT SETTINGS AND CREATING CARDINAL POINTS

13.	 Double-click on the Large BH relationship in the SA Treebar 
and follow the steps in Figure 5-32 (below):
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Figure 5-32.  Changing the 
measured side of a cylinder.

 a.	 Select Fit Settings.

b.	 Choose the first option in the section labeled Measured….

c.	 Click Ok. 

Notice the diameter value will increase since we have just changed 
the measured side of the cylinder from outside to inside (Figure 5-33).

Figure 5-33.  The diameter value 
reported for the criteria.

14.	 Follow the steps in Figure 5-34 (below) to set the cardinal 
points for the Large BH cylinder.
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Figure 5-34.  Creating Cardinal 
Points. 

d.	 Select Create cardinal points when fitting checkbox.

e.	 Click Cardinal Points Settings. 

f.	  Select the radio button next to Make Custom Group Name. 

g.	 Then type “Large BH Centers” in the Group Name: box.

h.	 Click Ok.

i.	 Click Ok.

SETTING A PROJECTION PLANE

This will set a geometry exactly in the plane it is getting projected 
to.  We are going to make four circles and then project them to our 
Datum A plane. 

15.	 Return to the Ribbon Bar and in the white box and type “Pat-
tern BH1”.

16.	 Change the Data Association, by selecting   

17.	 Select  , then select the points designated in Figure 5-35.  
This can be done by holding down the shift key and simul-
taneously holding down the mouse left click and dragging a 
box around the desired points.

18.	 Then hit Enter.
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Figure 5-35.  Selecting point for 
circle creation.

19.	 Repeat steps 14 – 17 while moving to the next hole “Pattern 
BH2”, and so on until four circles are created.

(The newly created circles may be oriented incorrectly, which is why 
we need to project them to a plane.)

20.	 Double-click on the Pattern BH1 relationship in the SA Tree-
bar and follow the steps in Figure 5-36 (below):

Figure 5-36.  Setting a projection 
plane for circles.
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a.	 Check the box next to Project to Plane.

b.	 Single left-click GR-Datum A to select the projection plane.

c.	 Click Ok.

APPLYING TO SELECTED RELATIONSHIPS 

	 The settings of one geometry relationship can be applied to 
other relationships of the same type.  We will apply the projection 
plane of Pattern BH1 circle to the rest of the holes in the pattern.  Fol-
low steps in Figure 5-37 and Figure 5-38.

Figure 5-37.  Applying settings to 
selected relationships.

a.	 Click Apply to Selected Relationships 

b.	 Check the boxes next to the other circle relationships.

c.	 Click Ok.
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Figure 5-38.  Selecting the set-
tings to apply to other relationships.

d.	 Check the box next to Projection Plane Settings. 

e.	 Click Ok.

Note:  A projection plane can be set prior to selecting points via the 
Features Tab of the ribbon bar.  See below.

Figure 5-39.  Setting a projection 
plane in the Features Tab.

CREATING DYNAMIC GEOMETRY

21.	 In the white box type “Datum B”, which will be the name of the 
created feature.

22.	 Change the Data Association, by selecting  .

23.	 Select  , then select the Datum B point group which will 
result in the creation of a plane.
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24.	 Press Enter to confirm your selection. 

25.	 Next click the drop-down form the line feature and select Two 
Planes Intersection (Figure 5-40). 

Figure 5-40.  Creating an intersec-
tion line.

26.	 In the following selection prompts, graphically select the Da-
tum A plane then the Datum B plane by single-clicking.

Fitting Geometry from Points
This tutorial provides a more in-depth look at feature construction 
and basic geometry fitting using points.

SA’s interactive Geometry Fit Interface is able to fit a wide variety 
of geometric shapes to any set of measured, constructed, or cloud 
points. It also provides an alternative means to build features. In this 
tutorial, you will learn how to best fit data to four of the most com-
monly created shapes: circles, cylinders, lines and planes.

1.	 To begin, open the tutorial file in SA included with your instal-
lation. Choose Help>Open Sample SA Files and select Geometry 
Fit.xit.

If you expand the items in the tree bar on the left, you will see that 
this file contains two separate instruments. The laser tracker mea-
sured points in the point groups Circle and Plane. The portable 
arm measured the points in the point group named Cylinder. These 
instruments were located to an established coordinate system using 
a best fit points to points transformation. This transformation was 
performed for visual purposes only and will not be demonstrated in 
this tutorial.

Best Fit a Plane to Points
There are several ways to fit geometry in SA. The simplest option is to 
right-click on the appropriate point group and select Fit Geometry from 
the context menu. If you’ve measured features into different point 
groups (as you should), this will fit the geometry to the entire point 
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group, which is almost certainly what you want.

2.	 Right-click the Plane point group and select Fit Geometry from 
the context menu.

3.	 The Geometry Fit Interface will appear. Here you can control 
the fit tolerance, points used in the calculation, output param-
eters, and everything else related to the fit. Select the Plane op-
tion from the drop down (Figure 5-41). Be sure to check the 
Make Geometry Relationship option in order to build a feature or 
you will simply build a static construction.

Figure 5-41.  The Geometry 
Fit Interface.

Fit Tolerance
4.	 Click on the Point List button. This will display the Geometry Fit 

Point Listing dialog (Figure 5-42) which shows you the fit error 
for individual points and permits the application of Tolerance 
Coloring Zones.

Tolerance Coloring Zones can be defined with values of your choos-
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ing and help you gauge how well the plane fits the selected data. You 
may change the tolerance zones as well as their colors by selecting 
the ellipses icon . In this example, one point lies outside of the 
0.015” tolerance zone. Four points are highlighted yellow because 
their error lies in the Limit 1 tolerance zone. All other points that are 
not highlighted are considered completely in-tolerance.

Figure 5-42.  A geometry fit’s 
point listing.

5.	 Let’s uncheck the out-of-tolerance point highlighted in pink 
to remove it from the fit. Once unchecked, the fit will need to 
be recomputed. Press the recompute button , which will 
have a dark blue background indicating the currently dis-
played fit data is not reflective of the current settings. Evaluat-
ing the new fit results, all points are now considered in toler-
ance. Close out the point listing dialog box.

Controlling Probe Offset
By selecting which probe you are using while collecting data, you will 
allow for SA to automatically calculate the offset when fitting geom-
etry. For this particular plane, a 1.5” SMR was used and as a result SA 
has already shifted the plane 0.75” to compensate for the probe ra-
dius (Figure 5-43).

Figure 5-43.  The plane is 
automatically offset from the measured 
points.

6.	 Click the Fit Details button. Among the statistics about the fit 
and the resulting geometry, the dialog also indicates that all 
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points have offsets of 0.75”. Close this window.

7.	 Check the Override checkbox (which overrides the target off-
sets to 0.0” by default) and notice how the plane now rests 
approximately on the measured points.

Figure 5-44.  Overriding the offset 
to 0.0”.

8.	 Uncheck the Override checkbox to again use the measured 
probe offset of 0.75”. 

In certain less common measurement situations (such as indirect 
measurement or when using a backing bar), you may wish to reverse 
the geometry offset direction or the direction of the resulting geom-
etry. The Reverse checkbox in the Planar Offset Direction box and the Reverse 
Object Normal Vector checkbox are intended to be used for this pur-
pose.

Creating Entities
It is sometimes desired to create probe compensated points—that is, 
points which represent the point of contact of the probe on the mea-
sured feature (instead of points representing the center of the probe). 
This can easily be accomplished by selecting the Offset Pts button. 

Exercise
Now that you have discovered how simple it is to interact with the 
geometry fit interface when constructing a best fit plane to points, it’s 
time to try an exercise utilizing three other geometric shapes with the 
remaining data on your own.

	■ Best fit a circle to its measured points.

	■ Best fit a cylinder to its measured points.

	■ Best fit a line to the cardinal points constructed from both the 
circle and cylinder.

If you need help or would like to check your work, follow the steps 
below.

Best Fit a Circle To Its Measured Points

1.	 All points for the circle fit were measured in the same point 
group. Right-click on the group in the tree and select Fit Ge-
ometry.

2.	 Click the Point List button. Several points are highlighted pink 
(Figure 5-45). Uncheck the point with the highest magnitude 
and recompute. Several points are still highlighted pink so 
uncheck the point with the highest magnitude once again 
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and recompute. All points are now in tolerance (Figure 5-45).

Figure 5-45.  The point list for the 
circle, showing many out of tolerance 
points.

Figure 5-46.  The fit improves 
dramatically after removing a few stray 
points.

3.	 Since the final step requires us to best-fit a line using cardi-
nal points, click the Cardinal Pts button. The point group Fitted 
CircleCardinal Points has been created. 

4.	 Click OK to accept.
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Best Fit a Cylinder To Its Measured Points

1.	 All points for the cylinder fit were measured in the same point 
group, so right-click on the group and select Fit Geometry.

2.	 Since the tolerance box lets us know that 0 of 16 points are 
out-of-tolerance (assuming the defined tolerance is accept-
able to us), we do not need to look at the point list.

3.	 Click the Cardinal Pts button to create the point group Fitted 
CylinderCardinal Points. 

4.	 Click OK to accept.

Best Fit a Line To The Cardinal Points Constructed from both the circle and cylinder.

1.	 The cardinal points constructed from the circle and cylinder 
are located in separate point groups, right-click on this gorup 
and select Fit geometry.

2.	 Select all points in both cardinal points groups by using either 
the F2 command or graphically clicking on the points them-
selves.

3.	 Of the five points, one is out-of-tolerance. Uncheck the point 
with the largest amount of error from the Point List dialog and 
recompute. 

4.	 Click OK to accept.

Conclusion
This tutorial has covered the basics of geometry creation and how to 
create a best fit plane. The interface we covered is generic for all the 
geometry fits which makes fitting geometries extremely simple.

Geometry Relationships
	■ Skill Level. Intermediate

	■ Description. In this tutorial, we will cover how to create geom-
etry relationships for reporting.

	■ Areas Covered. Creating Fit only, Compare only and Fit and 
Compare Relationships.

	■ Time to Complete. Approximately 20 minutes.

Fit and Compare Relationship
1.	 In SA, start by opening the Geometry Relationship.xit 

file from the Samples directory under Help>Open Sample SA Files.

2.	 We will first make a relationship that will take measured points, 
fit geometry to those points, and compare this geometry back 
to the nominal geometry. Navigate to Relationships>Geometry 
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Comparison>Fit and Compare to Nominal.   Select the nominal ge-
ometry and then select the points from the Measured Points 
point group that are above the red circle. Accept the default 
name for the relationship.

3.	 Double-click the Fit Circle - Big Hole relationship in the tree to 
expose the Geometry Relationship Report Options. Here you 
can control tolerance, fit constraint and geometry fit settings 
(Figure 5-47).

Figure 5-47.  The Geometry 
Relationship Report options.

4.	 Let’s change the Fit Settings so that circle is offset correctly. By 
default it was treated as an outside measured circle when in 
fact it was an inside measured circle (Figure 5-48).
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Figure 5-48.  Setting the circle fit 
options to offset outward.

5.	 Let’s set a tolerance for the X and Y components of 0.001”. 
Double-click the X column in the properties dialog. The Cri-
teria Properties dialog will appear. Set the tolerance for both 
high and low tolerances (Figure 5-49).  

Figure 5-49.  Modifying the high 
and low tolerances for the X attribute.

6.	 Now uncheck the Z and MagXYZ rows. Press OK to accept and 
close the dialog.

7.	 Right-click Fit Circle - Big Hole and select Add Callout (Figure 
5-50).
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Figure 5-50.  Adding the relation-
ship callout to the circle.

8.	 The best part about a Geometry Relationship is its ability to 
dynamically update--if the points change, the geometry and 
reported values will update accordingly. Select Instrument>Drag 
Graphically and move the instrument around in the graphical 
view. Notice how the geometry and callout update automati-
cally (Figure 5-51). Press ESC to cancel and restore the instru-
ment position.  

Figure 5-51.  The callout 
automatically updates as the situation 
changes.

Fit Only Relationship
1.	 Fit Only relationships are similar to Fit and Compare to nomi-

nal. Select Relationships>Geometry Comparison>Fit only and select 
the group of points that are rectangular in shape. You will be 
prompted to select a geometry to fit to the selected points-
-select Plane. Accept the default name.

2.	 Right-click Fit Plane and select Add Callout. Fit only relationships 
utilize the same Geometry Relationship Report Options as Fit 
and Compare to Nominal, although with different reported 
items (Figure 5-52 and Figure 5-53).
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Figure 5-52.  A fit-only relation-
ship.

Figure 5-53.  Geometry Rela-
tionship report options for fit-only 
relationships.

 

Compare Only Relationships
1.	 Now let’s compare two circles.  Select Relationships>Geometry 

Comparison>Compare Only and select the Nominal::Small Hole 
and Measurements::Small Hole Measured items from the tree 
and accept the default name.

2.	 Right-click Circle: Small Hole Measured - Small Hole and select 
Add Callout.

3.	 Compare only relationships utilize the same Geometry Rela-
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tionship Options as well (Figure 5-54 and Figure 5-55).

Figure 5-54.  Compare-only 
relationships.

Figure 5-55.  Geometry Relation-
ship report options for compare-only 
relationships.

 Conclusion
Geometry Relationships provide a quick and powerful method for 
creating and comparing geometry dynamically.
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Figure 5-56.  Various geometry 
relationships in a job.

Contoured Surface Alignment and Evaluation with 
Relationships

	■ Skill Level. Intermediate.

	■ Description.  In this tutorial, we will explore the advantages of 
relationships, and look at how to create them.

	■ Areas Covered. Points to Objects Relationships, Groups to Ob-
jects Relationships, Relationship Reports.

	■ Time to Complete. Approximately 20 minutes.

Building the Relationships
Relationships are an extremely powerful concept that enable real-
time examination of the positions and/or orientations between en-
tities in SA. Using relationships, you can get dynamically updated 
comparisons between measured and nominal points, points and ge-
ometry, coordinate frames, and other entities. There are two sides to 
relationships: the reporting side, and the relationship minimization 
side. Relationship minimization is available in SA Ultimate and higher, 
and will be explored in a different tutorial.

1.	 We’ll start by opening a tutorial file included with your instal-
lation of SA. In SA, choose Help>Open Sample SA Files. Choose the 
Relationships.xit file.

2.	 This file contains a sample CAD model of a hydroplane, along 
with a series of measured points along different surfaces of 
the model (Figure 5-57). Since this sample file already has con-
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structed relationships, let’s delete them to create them from 
scratch. In the tree, right-click on the Relationships category 
and choose Delete All from the menu. Confirm the deletion.

Figure 5-57.  The measured points 
have not yet been aligned to the model.

3.	 Currently, our measured points are not aligned to the model. 
That’s OK--for the purposes of this demo, we’ll ignore that fact. 
We now want to compare our measured points to the CAD 
surface, and see how our measured part deviates from nomi-
nal. We’ll use a series of Groups to Objects relationships to ex-
tract this information. In the menu, select Relationships>Groups 
to Objects. For the relationship name, enter Canopy.

4.	 The Query Point to Surface Options dialog will appear (Fig-
ure 5-58). This dialog allows you to specify how you want 
the relationship to compare the measured points to the sur-
face. The set of buttons at the top of this dialog allow you to 
specify how the resulting deviations will be depicted in the 
view. All four options give the same numeric result--they just 
control how the resulting deviation vectors are displayed, and 
the sense (positive or negative) of the deviation. We want to 
know the deviation from the CAD to the offset point (probe 
contact point). Leave all of the other options at their defaults 
and press Enter.
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Figure 5-58.  Query Point to 
Surface options.

5.	 When prompted for the groups, double-click the Canopy point 
group, then press Enter.

6.	 When prompted for the objects, double-click the HYDRODECK 
surface, then press Enter to complete the command.

7.	 Notice that the Canopy relationship has been added to the 
tree.  If you expand the relationship, you’ll see the absolute 
max error, RMS error, max signed error, and minimum signed 
error for the comparison of all of the points in the selected 
group to the selected surface.

8.	 Let’s open up the Relationship Report so we can see this re-
lationship’s values update in real-time. Double-click the Re-
lationships category. The Relationships Report dialog shows 
the desired relationship parameters for a given collection in 
real-time.

9.	 By default, only the relationship summary is displayed. Let’s 
turn on more details. Right-click the Canopy relationship and 
choose Report Options from the menu.  In the Report Options 
dialog (Figure 5-59), select the Single Line format:
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Figure 5-59.  Report Options for 
the relationship.

10.	 Click OK to accept the change. In the Relationship Report win-
dow, you can now see the deltas and resulting deviations for 
each point, as well as a summary for the relationship.

11.	 Let’s move the instrument up in Z. Since measurements are 
“tied to” instruments, the resulting measured points will move 
up in Z as well. Expand the Instruments category and right-
click on the instrument. Choose Properties from the context 
menu.  In the Instrument Properties dialog, click the Transform 
button. Click on the up arrow for the Z value to move the in-
strument up in Z, and watch as the Relationship Report up-
dates all of the calculations. After moving the instrument up 
a little bit in Z, close the dialog and click OK in the Instrument 
Properties dialog. Notice now that our measured points are 
now well above the CAD surface.

12.	 Close the Relationship Report window by clicking the Done but-
ton. Let’s create another relationship for the measurements 
of the sides of the Hydroplane. Choose Relationships>Groups to 
Objects and give the relationship the name Sides. Leave the pro-
jection options at the defaults and click OK.
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13.	 This time, let’s assign the point group to the relationship AF-
TER we’ve created it. This illustrates the idea that you can set 
up relationships in a nominal file prior to measuring anything, 
then assign measured points later. (You can even automati-
cally assign them AS you measure by “Trapping Measure-
ments”). Just press Enter to continue through the Groups 
prompt. As before, when prompted for the Objects, pick the 
HYDRODECK surface and press Enter to finish the command. 
Here, you’ve set the relationship up so that only the surface 
has been assigned--the groups involved in the relationship 
are not yet specified.

14.	 Expand the Sides relationship. Note that the tree indicates 
that there are No Points Specified. Let’s fix that. Right-click on 
the collection, and in the context menu, choose Associate 
Data>Points>Groups. Double-click the Top group and press En-
ter.

15.	 Let’s check to make sure that we’ve assigned the right objects 
to our relationship.  Right-click the Sides relationship in the 
tree and choose Highlight Entities. The HYDRODECK surface will 
highlight, as well as the Top point group. We just made a mis-
take! We accidentally selected the Top group instead of the 
Sides  group! No problem, we’ll fix it. From the menu, select 
View>Clear All Highlights to remove the highlighting. Right-click 
the collection, and repeat step 14, only this time, select the 
Sides group.

16.	 The collection should now be set up correctly. Go ahead and 
set up a Groups to Objects relationship between the Top 
group and the HYDRODECK surface as well, and name it Top.

17.	 Notice the horizontal plane named Tabletop Plane. This part 
was surveyed on a flat tabletop, so it would be impossible to 
measure the bottom surface of the object. Instead, we cre-
ated a nominal plane representing the top of the table, and 
measured a few points around the edges of the part to estab-
lish the table surface. Let’s build a relationship between the 
Plane points and the Tabletop Plane plane, which we’ll use in 
a later tutorial (Minimizing Relationships) to fit our measured 
data to the CAD model.

18.	 From the menu, select Relationships>Points to Objects. Give the 
relationship a name of Tabletop, and accept the default pro-
jection options. When asked for the points, double-click the 
6 green points around the edge of the model (the ones in the 
Plane group). We could have done this using a Groups to Ob-
jects relationship, but we wanted you to see a different way to 
create a relationship. Press Enter to accept the points.



112

SPATIALANALYZER USER MANUAL

19.	 When prompted for the objects, double-click the horizontal 
Tabletop Plane plane. Press Enter to complete the command.

20.	 We also measured a scribe line passing through our part 
which indicates the part’s centerline. We measured this line 
by placing the probe directly over the scribe line and measur-
ing the points. Repeat steps 18 and 19 one final time to create 
a relationship between the Centerline points and the CL Plane 
plane. Give the relationship a name of Centerline.  However, 
this time, in the projection options, override the target offset 
value to zero (Figure 5-60). Since we measured a centerline 
and want to compare it to a plane defining the centerline of 
the part, we do not want to account for a probe offset.  In oth-
er words, we want to compare the center of the probe to the 
plane directly, as seen at right.

Figure 5-60.  Overriding target 
offsets to zero.

21.	 We’ve now set up 5 relationships that show the real-time 
deviation between selected features and the corresponding 
measured points. As the instrument that measured the points 
is moved around, the relationships immediately recalculate 
and update the deviation values. This real-time re-calculation 
is very useful, particularly with instrument alignment and re-
al-time building/part mating processes.

Conclusion
In the next tutorial, Minimizing Relationships, we’ll explore the power 
of Relationship Minimization and discover how it can be used to per-
form a variety of complex alignments with constraints.
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You may want to do the same with the Surface Profile Check 2 vector 
group created as part of this evaluation.

Figure 5-61.  Additional details 
tables included for a failed check.

When a check fails, it will report two values for troubleshooting pur-
poses: the Measured Deviation and Distance Out of Tolerance. The first 
number (0.0208) is the Measured Deviation or the size of the tolerance 
zone required for the part to pass. The second number (0.0128), is the 
Distance out of Tolerance or the necessary expansion of the tolerance 
zone in order for the part to pass. For the above profile check, the sum 
of the check tolerance plus the Distance Out of Tolerance will equal 
the Measured Deviation (0.008+.0128=.0208). 

Conclusion

In this tutorial, we covered how to import CAD with GD&T annota-
tions and how to create, measure and report feature checks.
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Tutorial Index:
“” on page 115

The following tutorials are designed to guide you through various topics 
in SA and get you up and running as quickly as possible. They are specific 
topic based step by step guides to accomplishing specific tasks but as a 
whole they should help directly though the software and help to under-
stand the workflow and approach to operations within SA. 

For greater depth and theory consider one of our courses and contact 
training@kinematics.com for more details.

Cloud Inspection
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Cloud Based Part Inspection with an Arm
	■ Skill Level. Beginner.

	■ Description. In this tutorial, we will cover how to scan a part , 
align to CAD and extract features. 

	■ Areas Covered. 

	■ Time to Complete. Approximately 15 minutes.

Start SA and Connect Arm 
The first step is to connect to a PCMM Arm with a scanner. For this 
tutorial we will use a Hexagon Absoulte arm.

1.	 In SA, start a new job file by selecting File>New File from the 
menu or choosing the New File Icon from the Quick Access  
toolbar.

2.	 Go to the INSTRUMENT tab. In the INTERFACE section, select 

the add instrument icon,  .

3.	 The ADD INSTRUMENTS TO SA dialog will open.  Select the 
arm you want to connect from the list Figure 6-1 below. 

Figure 6-1.  Add Instrument 
Options.

 A.	 Select the All Instruments filter if it is not already selected.
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	■ B.	 Single left-click the arm you would like to add to the 
job file.  The Hexagon Absolute is selected here, but you can 
also make a selection from the or Faro or API sections as well.

4.	 In the INSTRUMENT tab In the INTERFACE section, select the 

Connect icon  , to connect the arm. For arm driver infor-
mation or connection troubleshooting refer to the arm quick-
start guild for your model arm. The arm interface should ap-
pear 

Figure 6-2.  PCMM Arm Instrument 
Toolbar

	■ A. 	 The probe diameter 

	■ B.	 The Collection Group and Target Name used for the 
next measured point.

	■ C. 	 The 3 primary measurement modes (Single Point, Spa-
tial Scan, and Cloud Scan)

	■ D.	 Checks and Utilities.

Many scanners such as the Hexagon Absolute change measurement 
modes automatically between point probing and cloud scanning. 

Scanning a Part on a Tabletop

Clipping planes define an exclusion zone which eliminates unwanted 
cloud data. Assuming you have a part on a flat surface, this surface 
can be measured as a plane and used for cloud data “clipping”. 

1.	 To measure a clipping plane you need to first decide if you 
want to measure it with points or by scanning the plane, and 
set the measurement mode you want, to begin we will use 
points.

2.	 From the Clouds & Surface Tab select Prepare Clipping Plane (Fig-
ure 6-3).
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Figure 6-3.  Selecting Prepare 
Clipping Plane.

3.	 Measure the table top or surface you are using to define the 
clipping plane (the surface your part is sitting on). The Cloud 
Clipping Plane we added should be actively trapping and col-
lect the measurements, automatically fitting a plane (Figure 
6-4).

Figure 6-4.  Trapping into a Clip-
ping Plane feature

4.	 Stop Trapping. This can be done but pressing the Next but-
ton on the arm. It can also be done from the controls on the 
Inspection bar or by directly right-clicking on the Clipping 
Plane in the tree.

Configuring the View and Scanning your part

The most important thing when scanning is to make sure you have 
good scan coverage. The easiest way to see that is to enable the in-
strument view and zoom in tight. 

1.	 From the Home tab in the View section select Enable Viewpoint 
from Instrument Updates.

Figure 6-5.  Enabling viewpoint 
from Instrument. 

2.	 Change the Group name in the instrument toolbar, this group 
name will be used for the newly measured cloud. 
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3.	 Scan the part. 

Compare to CAD

1.	 Import CAD by going to File>Import>CAD Formats . CAD im-
port can be performed at any point in the measurement pro-
cess and can be performed by simply drag-dropping a file 
into the graphics.

2.	 Align your scan to the CAD file by right-clicking on the cloud 
and selected Align to CAD. When prompted select the CAD 
model(s) you have scanned and press OK. 

You will see an alignment report like this (Figure 6-6). If you are happy 
with the results press Yes to accept. But if the fit looks questionable 
press the Perform N-Point Alignment button. 

 

Figure 6-6.  Cloud to CAD Align-
ment Results.

To Align using an N-Points Alignment perform the following steps:

1.	 Arrange the second graphic window and Align Cloud to CAD 
dialog so that you can see both the CAD model and cloud 
scan to facilitate selection of corresponding points such as 
the below (Figure 6-7):
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Figure 6-7.  Align Cloud to CAD 
windows and arrangement.

2.	 Press the Control Points button in the Align Cloud to CAD dialog 
and select at least 3 points on the CAD model.  These points 
should be on surfaces with good scan coverage. 

3.	 Press the Rough Align Points button and graphically select a 
corresponding cloud point from the axillary view for each of 
the control points you placed on the CAD.

4.	 Press Perform Alignment and accept the alignment by press-
ing Exit when you are happy with the results. 

Report Overall Part Acceptance with a Color Map

Rather than using vectors to report deviations you can get much nic-
er results with cloud data by using a voxel display. 

1.	 Disconnect the arm so that it is no longer connected to SA. 

2.	 Build a cloud to CAD relationship between your scan and the 
CAD model.

3.	 Adjust Voxel Settings and colorization levels to build heat map

Report  Individual Features 

Identify Features to extract

Extract features 
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Add overview heatmap to Report

Add features to report
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Tutorial Index:

Feature Measurement

“Inspection with GD&T” on page 124

“Designing a GD&T Inspection” on page 130

The following tutorials are designed to guide you through various topics 
in SA and get you up and running as quickly as possible. They are specific 
topic based step by step guides to accomplishing specific tasks but as a 
whole they should help directly though the software and help to under-
stand the workflow and approach to operations within SA. 

For greater depth and theory consider one of our courses and contact 
training@kinematics.com for more details.

GD&T Inspec-
tion



124

SPATIALANALYZER USER MANUAL

Inspection with GD&T

	■ Skill Level. Beginner.

	■ Description. In this tutorial, we will cover how to perform a 
GD&T inspection with nominal CAD and native GD&T annota-
tions.

	■ Areas Covered. Importing CAD with GD&T annotations, cre-
ating Datums and Feature Checks, Associating/Trapping mea-
surements and Reporting.

	■ Time to Complete. Approximately 15 minutes.

Importing CAD with GD&T Annotations

The first step for this tutorial is to import the nominal CAD model with 
GD&T annotations. 

1.	 In SA, start a new job file by selecting File>New File from the 
menu or choosing the New File Icon from the Quick Access  
toolbar.

2.	 Import the native CAD model with GD&T annotations by se-
lecting File>Import>CAD File Formats>Direct CAD Access or use the 
Auto Import  button on the Quick Access toolbar.

3.	 Choose SA DEMOPART_inches.CATPart from the Samples 
file folder in the SpatialAnalyzer install directory (C:\Program 
Files (x86)\New River Kinematics\SpatialAnalyzer xxxx.xx.xx\
Samples).

4.	 When the Choose CAD Features dialog appears (Figure 7-1), 
turn off the points and lines but make sure the Annotations are 
selected and press OK.  

Figure 7-1.  The Direct CAD Access 
settings with the Selective Importer.
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5.	 Once imported, you will find the Annotations category is created 
in the tree along with the Surfaces, which contains each indi-
vidual annotation for the model Figure 7-2.

 

Figure 7-2.  Annotations in the 
graphical view.

Annotations define the tolerances, datums used and all the graphical 
aspects of the annotation attached to the model. It also holds the link 
to the specific CAD faces used for analysis. 

You may also see a new collection appear following the import.  We 
will bring in the saved views from the CAD model for the annotations 
as callouts that you can use for reporting if desired. 

Creating GD&T Datums and Feature Checks

For this tutorial we will inspect only one of the GD&T Features. 

6.	 Create a New Collection in the SA Tree bar and name it *GD&T”. 
Just like annotations, Feature Checks cannot be moved to an-
other collection once created so be sure the GD&T collection 
you create is the Default Collection.   

7.	 Right-click Geometrical Tolerance.34 in the tree and choose 
Make Feature Check. You will notice two new categories are cre-
ated, GD&T Datums and Feature Checks. 

These two new categories act as bins for the respective measure-
ments.  Here we wanted to build a feature check for a Surface Profile 
annotation which referenced 3 datum features so the datum features 
were built for you as well automatically. 
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Figure 7-3.  Feature Checks and 
Datums built in the tree

Inspecting GD&T Datums and Feature Checks

1.	 The next step is to associate measured points to the respec-
tive GD&T Datum or Feature Check.

	■  If you already have points in the job file you can right-click on 
the feature check and select Associate Points.

	■ For this tutorial we will assume that an instrument is present. 
So let’s add an instrument and run the interface. 

2.	 Now that the instrument is added and running, open the In-

spection Bar from the Home tab  and double click on the 
feature you want to measure in order to start trapping (Figure 
7-4).

Figure 7-4.  Selecting by double 
clicking on the feature of interest in the 
Inspection bar.

3.	 Once measurements are complete for a feature, press the 

next button  to advance to the next feature and continue 
measuring. Once all measurements are made the inspection 
is complete.
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4.	 Since we did not take any actual measurements, lets open 
GD&T with Multigage.xit from the Samples directory 
under Help>Sample SA Files.

5.	 In the GD&T with Multigage.xit file, all the GD&T Datums 
and Feature Checks have points associated.

Reporting the Results

1.	 To see the results of the Feature Checks evaluation, simply 
select the Feature Check of interest and the results will dis-
play in the Report Bar. If the report bar is not visible, turn it on 

using Reporting>Report Bar  . By default only a minimum 
pass/fail result is displayed:

Figure 7-5.  Feature check results 
for a surface profile check.

2.	 Right-click the Feature Checks category in the tree and select 
Evaluate All Checks. 

3.	 To build a summary table for all, or a selection of check re-
sults, there is an additional option under the Feature Checks 
category to Create Inspection Summary Table. In this file, a table 
has already  been built for you. 

4.	 Navigate to the GDT Feature Check Summary within the Custom 
Report Tables section, right-click on it and select Add to Active SA 
Report (Figure 7-6).
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Figure 7-6.  A Custom Summary 
Table with GD&T feature check results.

Note that one of the checks in this file failed. Lets add additional de-
tails on this particular check to the report. 

5.	 Right-Click on the Surface Profile Check 2 Feature Check in 
the tree and select Reporting Options. 

6.	 Enable additional reporting tables for this check as follows 
(Figure 7-7), then press OK.

Figure 7-7.  Feature Check Report-
ing Options

7.	 Add these additional tables to the report by right-clicking on 
the Feature Check and selecting Add to Active SA Report. 
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8.	 You may want to do the same with the Surface Profile Check 2 
vector group created as part of this evaluation.

Figure 7-8.  Additional details 
tables included for a failed check.

When a check fails, it will report two values for troubleshooting pur-
poses: the Measured Deviation and Distance Out of Tolerance. The first 
number (0.0208) is the Measured Deviation or the size of the tolerance 
zone required for the part to pass. The second number (0.0128), is the 
Distance out of Tolerance or the necessary expansion of the tolerance 
zone in order for the part to pass. For the above profile check, the sum 
of the check tolerance plus the Distance Out of Tolerance will equal 
the Measured Deviation (0.008+.0128=.0208). 

Conclusion

In this tutorial, we covered how to import CAD with GD&T annota-
tions and how to create, measure and report feature checks.
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Designing a GD&T Inspection
	■ Skill Level. Beginner

	■ Description. In this tutorial, we will cover how to design a 
GD&T inspection routine for repeated use.

	■ Areas Covered. Importing CAD with GD&T annotations, creat-
ing Datums and Feature Checks and assigning nominal points 
and views.

	■ Time to Complete. Approximately 15 minutes.

Importing CAD with GD&T annotations

The first step for this tutorial is to import the nominal CAD model with 
GD&T annotations. If your CAD models do not contain GD&T annota-
tions, please refer to the tutorial on creating GD&T annotations.

1.	 In SA, start a new job file by selecting File>New from the menu 
or choosing the New File Icon from the main toolbar.

2.	 Import the native CAD model with GD&T annotations by se-
lecting File>Import>Direct CAD Access or use Auto Import from 
the main toolbar.

3.	 Choose Sample CAD.CATPart from the Samples file folder 
in the SpatialAnalyzer install directory. See Direct CAD Access 
for supported formats.

4.	 When the Direct CAD Access Settings dialog appears, make 
sure the Annotations option is selected and press OK (Figure 7-9).

Figure 7-9.  Ensuring that the An-
notations option is selected in the Direct 
CAD Access import settings.

5.	 Once imported, you will find that the Annotations group is 
created with the imported annotations.  

Note:� This tutorial requires 
SA Ultimate.
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Creating GD&T Datums and Feature Checks

For this tutorial we will inspect only one of the GD&T Features.

1.	 Right-click Geometrical Tolerance.1 in the tree and choose Make 
Feature Check. You will notice two new categories are created, 
GD&T Datums and Feature Checks. These two new categories 
act as bins for the respective measurements.

Designing the Inspection Routine

Now that the feature checks have been made, the inspection routine 
can be designed which will set views and nominal points for each 
GD&T Datum and Feature Check.

1.	 To design an inspection, simply right-click collection A and 
select Inspect>Design. A dialog will appear which contains op-
tions for the design of each GD&T Datum or Feature Check 
(Figure 7-10).

Figure 7-10.  Options for design-
ing an inspection.

2.	 The design dialog will guide you through the design of each 
GD&T Datum or Feature Check. So for Datum A, orient the 
view how you would like the user to see Datum A during in-
spection. Now let’s put some nominal inspection points on 
the surface by clicking the areas for inspection on Datum A. 
Use the minimize button to minimize the dialog so more of 
the graphical view is available (Figure 7-11).
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Figure 7-11.  The options are now 
minimized.

3.	 Now that Datum A is designed, proceed to the next GD&T Da-
tum or Feature Check by clicking to advance. Do the same 
for the remaining GD&T Datums and Feature Checks. Once 
complete, close the dialog using .

Rehearsing a Designed Routine

Now that the inspection routine is designed, it can be rehearsed to 
check the work flow, nominal points and views.

1.	 To start Rehearse mode, right-click collection A and select 
Inspect>Rehearse. A dialog will appear with options regard-
ing the rehearsal (Figure 7-12). During this rehearsal mode, 
the mouse acts as an instrument. So with each mouse click, a 
measurement is simulated with some random error.

Figure 7-12.  Rehearsing the 
inspection.

2.	 Now that the rehearse mode is started, let’s click the dot for 
Datum A. With each click a measurement is simulated and the 
guiding dot will advance. Continue clicking the dots for Da-
tum A. Once all the dots for Datum A are clicked, the inspec-
tion will advance to the next GD&T Datum or Feature Check.
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3.	 Do the same as above for the remaining GD&T Datums and 
Feature Checks. Once complete, close the dialog using .

Conclusion

We have just designed a routine that can be used to guide a user 
through an inspection process. A user can now simply right-click the 
collection of interest and select Inspect.
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Tutorial Index:
Reporting

“Basic Point Analysis” on page 136

“Creating Callouts” on page 142

“Reporting With SA Reports” on page 146

The following tutorials are designed to guide you through various topics 
in SA and get you up and running as quickly as possible. They are specific 
topic based step by step guides to accomplishing specific tasks but as a 
whole they should help directly though the software and help to under-
stand the workflow and approach to operations within SA. 

For greater depth and theory consider one of our courses and contact 
training@kinematics.com for more details.

Reporting
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Analysis and Reporting 

Basic Point Analysis

	■ Skill Level. Beginner.

	■ Description. In this tutorial, we will cover how to perform ba-
sic point analysis.

	■ Areas Covered. Query Point to Point, Query Point to Object 
and Query Points to Objects.

	■ Time to Complete. Approximately 20 minutes.

Creating Entities to Work With
For this tutorial, we want to create some points and geometry to play 
around with, so we’ll start out by creating those entities first.

1.	 In SA, start a new job file by selecting File>New from the menu 
or choosing the New File Icon from the main toolbar.

2.	 Create a set of random points by using Ctrl+Alt+Z or Constru
ct>Point(s)>Layout>Random Points. Use the default settings.

3.	 Now create a plane by using Construct>Plane(s)>Enter and ac-
cept the default settings.

Calculating Point to Point Distance
Calculating the distance between two points is a very common analy-
sis operation and provides a good starting point for learning basic 
analysis in SA.

1.	 Using the points we created above, let’s determine the dis-
tance between two points. Use Query>Point to>Point or Ctrl+D 
and select two points by single-clicking in the graphical view.

2.	 The distance between the two points will be reported in the 
Query Results dialog (Figure 8-1). The delta values for each 
component are expressed in the active coordinate frame. The 
point to point distance is calculated from the centers of the 
selected points. Any target offset, if present, will be ignored.

Figure 8-1.  The query results 
dialog.
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3.	 To record the point to point check the Create Dimension op-
tion check box in the bottom left corner. This will create a di-
mension stored in the SA tree as well as display the deviation 
graphically (Figure 8-2).

Figure 8-2.  The query as a Dimen-
sion.

Calculating Point to Object Distance
Another common analysis operation is calculating the distance be-
tween a point and an object, which is reported as the closest distance 
between that point and the object. Let’s calculate the distance be-
tween one of the random points and the plane we created earlier.

1.	 Select Query>Point to>Object from the menu. Select one of the 
random points and then the plane. The resulting distance be-
tween the point and the plane is displayed (Figure 8-3). No-
tice that the dx and dy values are zero. Since we’re comparing 
a point to a plane, and the plane’s normal is along the Z axis, 
there is no delta-x or delta-y component. (Said another way, 
the closest point on the plane to the selected point is directly 
below that selected point).  

Figure 8-3.  Querying a point to 
an object.

2.	 Like the Point to Point query, the results are stored in the tree 
as an event (Figure 8-4).
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Figure 8-4.  The Point to Object 
query as a dimension.

Dimensions of different types, both linear and angular, can be added 
through the toolkit as well using the selection of icons on the Report-
ing tab. Once added dimension can also be formatted through their 
properties in any way that you need (Figure 8-5). 

Figure 8-5.  Dimensions and their 
properties

Calculating Multiple Points to Object Distanc-
es

During analysis operations it is often desirable to calculate the dis-
tance between multiple points and objects. To do this, a Points to Ob-
jects query can be performed. The output of this query is a vector 



139

CHAPTER 8 ■ Reporting

group which gives a numerical and graphical representation of the 
point to object deviations.

1.	 Go to Query>Points to>Objects and select all of the random 
points. Then, select the plane when prompted for the objects. 
The Query Point to Surface Options dialog will appear (Figure 
8-6). Here you can choose which direction the Vector should 
point and access general options. By default the vector (whis-
ker) will point from the object to the point. Let’s also create 
a point group with points that are offset toward the object 
by the target radius. (Think of these as the “contact points”, or 
the points where the measurement tooling would have been 
touching the object being measured). Press OK.  

Figure 8-6.  The options for query-
ing points to objects.

2.	 A Vector Group will be created and the properties dialog will 
appear (Figure 8-7).  



140

SPATIALANALYZER USER MANUAL

Figure 8-7.  The vector group 
properties dialog.

3.	 To change the appearance of the vectors change the magnifi-
cation, size, and style of the vector. Change the magnification, 
vector style and blotch size to match Figure 8-8.  

Figure 8-8.  The Vector Group 
Display Options.

4.	 Now change the colorization of the vectors and apply a tol-
erance for colorization. There are four different colorization 
methods (Figure 8-9). Choose Toleranced (Go/No-Go).  
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Figure 8-9.  Colorization options.

Now the vector group reflects the display and colorization changes 
(Figure 8-10).

Figure 8-10.  The result.
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Creating Callouts

	■ Skill Level. Beginner.

	■ Description. In this tutorial, we will cover how to create callout 
views with graphical annotations.

	■ Areas Covered. Creating a Callout View, Creating Callout An-
notations and Locking the view.

	■ Time to Complete. Approximately 10 minutes.

Creating A Callout View

1.	 In SA, start by opening the Blower Shroud.xit file from 
the Samples directory under Help>Open Sample SA Files.

2.	 Before we create a callout view, let’s render the model in solid 
shaded mode by clicking the Solid icon .

3.	 Now create a callout view by clicking the Callout icon . Call-
out 1 view will be created in the tree and will be active (Figure 
8-11).

Figure 8-11.  The newly-added 
callout view.

Creating Callout Annotations
1.	 Let’s create a callout annotation in the graphical view. Start by 

clicking the arrow by the icon. A series of annotation types 
will appear. Let’s start with a simple Point Comparison. Select 
Point Comparison from the drop down and select two points to 
compare. An annotation will appear and you can now place 
the annotation accordingly by left-clicking and dragging (Fig-
ure 8-12).
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Figure 8-12.  The point compari-
son callout.

2.	 Now let’s create some annotations for a few of the vectors in 
the vector group. Start by clicking the arrow by the icon 
and select Vectors. When prompted select the vectors of inter-
est. The Vector Callouts dialog will appear with view options 
(Figure 8-13). This dialog will allow you to select display op-
tions for the callouts. Once satisfied, press OK (keep callouts). Feel 
free to place the annotations accordingly by left-clicking and 
dragging (Figure 8-14).    

Figure 8-13.  The Vector Callouts 
dialog.
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Figure 8-14.  Vector callouts have 
been added.

Locking the Callout view
1.	 Right-click on Callout 1 in the tree and select Properties (Figure 

8-15).

Figure 8-15.  The Callout Page 
properties.

2.	 Select Lock in the Viewpoint section. When the viewpoint is 
locked, the view will be recalled when the callout is activated.

3.	 Double-click Callout 1 in the tree. This will deactivate the call-
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out.

4.	 Rotate and zoom the view to be different than the callout.

5.	 Now double-click Callout 1 in the tree. This will activate the 
callout. Notice how the view returns to the locked position.
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Reporting With SA Reports

	■ Skill Level. Beginner.

	■ Description. In this tutorial, we will cover how to create a re-
port using the SA Report designer.

	■ Areas Covered. Creating an SA Report, dragging out items, 
changing report options.

	■ Time to Complete. Approximately 15 minutes.

Creating an SA Report
In this tutorial, our goal is to create a report comparing measured data 
to CAD. We will use a sample file and create the report from that data.

1.	 In SA, start by opening the Query Points to Surface.
xit file from the Samples directory under Help> Open Sample 
SA Files. 

2.	 Before we start the report, let’s render the model in solid 
shaded mode by clicking the Solid icon .

3.	 Create an SA report by selecting Report>Add SA Report. The SA 
Report editor will appear, and the report is automatically 
stored in the tree under the SA Reports category (Figure 8-16).    

Figure 8-16.  The newly-added 
report.

Figure 8-17.  The Report Designer.

4.	 Let’s add an item to the SA Report. Click and drag the Boat 
Error_Vectors_Blotches vector group into the report (Figure 

Note:� This file contains data 
that was measured with a 

portable CMM arm.  The measure-
ments were compared to the 
nominal model using Query> 
Points to> Objects.
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8-18).

Figure 8-18.  Adding a vector 
group to the report.

5.	 Now let’s change the reporting options for the vector group 
so that only the vector magnitude will be displayed. Right-
click anywhere on the vector group table and select Report Op-
tions.

6.	 Uncheck the Point A, Point B and Delta components and press 
OK.  The SA Report will update and reflect your changes.

7.	 Let’s add an image of the current graphics view to the report. 
Orient the SA graphics as you’d like, and press the Picture icon

in the toolbar. The picture will be stored in the tree, as pic-
tured in Figure 8-19.

Figure 8-19.  The screenshot has 
been added to the tree.

8.	 Click the photo, drag it over a table in the SA Report, and re-
lease the mouse button to add the photo to the report.

9.	 The photo will have the same aspect ratio (width to height 
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ratio) as the graphical view when it was taken. If you need to 
resize the image, hold down Ctrl and drag over the image, 
or grab a corner of the image to resize it as necessary. Drag 
the tables around to rearrange the report as you’d like (Figure 
8-20).  

10.	 Items in a report can be moved by dragging them manually 
and positioning them as you would like. To dynamically ad-
just the placement of items in the report right-click and select 
Auto-Arrange> Set Auto-Arrange Start. This will place a start 
tag in your report for where you want selection to start. 

11.	 Right-click again and select Execute Auto-Arrange to remove 
overlap in tables below your start tag . If you noticed there is 
also an option to set a stop point for more control or to select 
all the entities so you can manually move them as a group. 

Figure 8-20.  Auto-Arrange 
Controls

12.	 The report is automatically saved into the tree. If you’d like, 
you can print the report, send it to a PDF, or export to Excel.
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Tutorial Index:
Instrument Operations

Building your own measurement profiles

Temperature Compensation

Holding Level

“How to Get Accurate Time Stamps with Points in SA” on page 152

Using External Triggers for synchronized measurement

Trans-track operations

The following tutorials are designed to guide you through various topics 
in SA and get you up and running as quickly as possible. They are specific 
topic based step by step guides to accomplishing specific tasks but as a 
whole they should help directly though the software and help to under-
stand the workflow and approach to operations within SA. 

For greater depth and theory consider one of our courses and contact 
training@kinematics.com for more details.

Advanced Instrument 
Operations
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Instrument Operations

How to Get Accurate Time Stamps with Points in SA

As you may have noticed, measurement data from a tracker is only re-
ported to the nearest second within SA.  Read on to find out why, plus 
how to measure at precise increments and how to obtain sub-second 
timestamps in SA.  

The first thing to keep in mind when attempting to record time with 
your measurements is that the vast majority of measurements are av-
erages, not individual samples. If you are measuring “discrete” or aver-
age points over a period of one half to two seconds, time stamps may 
not be meaningful.  Precise time stamps mainly have relevance when 
taken from a single sample obtained from a stream of points where 
the time and sample correspond. 

Obtaining measurements at exact increments:
Standard point measurements are not a fast thing. They include a lot 
of measurement data and are passed to SA in packets to ensure there 
is no slow downs. The typical time stamp recorded with all points is 
used as a reference only and reflects the time to the second when the 
point was created in the tree, not when it was measured. 

In order to record an accurate time with each measurement you will 
want to use either a Spatial (distance base) or Temporal (time based) 
measurement. Using a custom measurement profile will allow you to 
set a specific rate that suits your needs if you want a temporal mea-
surement. 

A basic temporal scan profile that will take a single sample at an exact 
time period, is simple to create.  Start by opening a “Watch Update” 
profile.  You will see the Acquisition is set to “Temporal Scan” and the 
Operation is set to “Send Updates to SA.”  If you change the Operation 
to “Send Points to SA,” you will have created a Temporal Scan profile. 
The Sampling Frequency can be used to adjust the rate at which a 
point is recorded.  Just use the “Save As” button to define and save 
that new profile so that you can use it again later (Figure 9-1).  
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Figure 9-1.  Modifying a Watch 
Update profile

Spatial (distance based) measurement profiles can also be used by 
choosing any measurement profile with an Acquisition set to “Spatial 
Scan”. In a spatial scan the tracker will still be measuring at a constant 
sample rate but only measurements captured beyond pre-set dis-
tance or “Increment” will be recorded. This will capture points with an 
even distribution and the controller timestamp will still be available 
for that point.

Measurement profiles can be edited and adjusted as needed.  When 
you save measurement profiles, they are saved in the persistence file.  
However if you would like them to be saved more permanently, or if 
you would like to move them to another machine, you can use the 
folder icon to manage and export your saved measurement profiles 
in a *.msp file.  

Saving data in Point Sets
Starting with the 2020.04.09 version of SA, a new Point Sets data for-
mat is available. Point Sets provide a merged point format that allows 
many individual points to be saved as part of a single object, much in 
the same way point clouds record the point information. Using Point 
Sets provides the advantage of keeping the tree manageable and al-
lowing many more points to be measured in a single job file at faster 
rates than are available with points.

To record data in a point set, right-click on the instrument in the tree 
and select “Enable Point Set Scan Mode”. This will record points mea-



154

SPATIALANALYZER USER MANUAL

sured with a scan measurement profile as part of a Point Set, much 
like recording into a cloud (Figure 9-2). The difference is that each 
points includes a name, XYZ, and timestamp is recorded with each 
entry. This time is recorded directly from the instrument and is only 
adjusted such that the time is zero’ed when the scan is initiated. The 
meta data typically stored within each point’s observation is stored 
once with the Point Set properties and can be passed to individual 
entries if you need to build individual points from the Point Set later. 

Figure 9-2.  Example Point Set 
Data.

Recording Frame Sets with a 6D probe
If you have a 6D probe and can record measurements as Frames 
within SA, then starting in SA Release 2018.05.01 these frames can be 
collected as a “Frame Set”. Much like a 6D point cloud each frame is 
a separate piece of a single item within a the tree. In addition to posi-
tion and rotation information, a frame also has the accurate controller 
time saved with it. 

By default frame measurements are recorded as individual frames 
stored separately within the tree. However, if you right-click on the 
frame category you will find an option to “Enable Frame Set Scan 
Mode” (Figure 9-3). This can be very helpful if you plan to measure 
many frames because recording each frame separately can make 
navigating your tree much more difficult. If you measure into a Frame 
Set then each scan can be separately saved and contain thousands of 
individual frames:
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Figure 9-3.  Enable Frame Set Scan 
Mode.

A frame set, much like a point cloud, will provide the frame count and 
duration of the scan. It also provides the visual control over all the 
frames saved within it, which can be used to visualize the 6D move-
ment of a probe through space. To access the transform and time in-
formation from any individual frame saved with a frame set, it can 
be accessed by double clicking on it from within the graphic view 
(Figure 9-4):
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Figure 9-4.  Frame Set Properties.

Obtaining tracker time with each sample:
There are applications that require obtaining the exact measurement 
time with each sample sent from the tracker.  When data is sent to SA, 
it is sent as part of a network packet.  Therefore, the time received in 
SA is still rough even when you break it down per sample.  The inter-
nal clock on the tracker versus the Windows system clock is extremely 
accurate, so you need to be able to access that time.  Using UDP will 
allow you to obtain the actual measurement time used by the tracker 
when each sample was taken.  To capture UDP packets you must first 
tell the tracker interface to transmit the data.  Within the tracker inter-
face, go under Utility>UDP Data Stream and turn on 3D updates and 
Instrument Time Stamps (Figure 9-5):
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Figure 9-5.  Enabling UDP Data 
Broadcast.

The next step is to record the data.  Open the UDP Monitor directly 
from the Help tab in the Diagnostics section (Figure 9-6):

Figure 9-6.  Open the UDP Monitor 
from the Help tab. 

This utility will display line per line the coordinates and the exact con-
troller time stamp with each sample passed across the UDP network 
in an asci format.  This data can be saved and processed in a spread-
sheet program like Excel (Figure 9-7).

Figure 9-7.  Recorded Data in the 
UDP 

Unlike TCP/IP communication, UDP broadcasting does not require 
“handshaking” for data transmission. There is no guarantee that trans-
mitted data is received, so some packets can be lost depending on 
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network traffic.  This means you are not guaranteed a recording of 
every sample, but each sample and the time captured with it will be 
as accurate as the tracker can record.

UDP Data Streaming opens a vast array of possibilities for harnessing 
tracker data in custom ways.  For example, you can write applications 
to intercept this tracker data and perform custom analysis for hard-
ware control operations, or you can write your own custom watch 
window applications for near real monitoring processes.
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Running Multiple Laser Trackers
	■ Skill Level. Advanced

	■ Description. In this tutorial, we will cover how to run two laser 
trackers simultaneously.

	■ Areas Covered. Adding Instruments, Running Instrument In-
terfaces, IP Addresses, Watch Windows

	■ Time to Complete. Approximately 30 minutes.

Configuration Requirements

When running multiple instruments simultaneously, network con-
figuration must be considered. For this exercise we will use two laser 
trackers which have different IP addresses. We will configure the PC 
with dual IP address to accommodate. Please refer to the IP Address 
Basics section for more information on setting multiple IP Addresses. 
For this example we used one PC with a network router connecting 
the two instruments to the PC.

Adding the Instruments

1.	 Select Instrument>Add or the Add Instrument icon . Navigate 
the instrument list and select your Laser Tracker type,   then 
select Add Instrument at the bottom of the dialog.

2.	 Repeat the above step and add a second Laser Tracker.

3.	 Now run the instrument interface by selecting Instrument>Run 
Interface Module and select Laser Tracker. The SA Network Brows-
er will appear (Figure 9-8). Select the first laser tracker under 
your SA file name and press OK. Depending on your laser track-
er type, you might be prompted to enter the respective IP ad-
dress. If prompted, enter now. Now the instrument interface 
is up and running for the first instrument.
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Figure 9-8.  Selecting the appropri-
ate instrument to connect to.

4.	 Repeat the above step for the second laser tracker (Figure 9-9).

Figure 9-9.  Starting a second 
interface.

Common Network

With both instruments running, we will need to bring the instruments 
into a common coordinate system.

1.	 With the first tracker, measure a set of common points that 
can be seen from both instruments, and name the group ac-
cordingly.

2.	 Repeat this process for the second instrument.

3.	 Now best-fit the second laser tracker to the first laser track-
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er. Right-click the second laser tracker in the tree and select 
Locate. Choose Best-Fit and choose the first tracker’s control 
points as the Nominal Group and the second tracker’s control 
points as the Measured group.  Accept the best-fit and now 
the two laser trackers are located to one another (Figure 9-10).

Figure 9-10.  Fitting the two 
instruments together.

Working with both instruments simultaneously

To demonstrate working with multiple instruments simultaneously, 
let’s measure a plane and then watch the deviation of the plane with 
both laser trackers.

1.	 Measure points on the floor with one of the laser trackers.

2.	 Create a plane from the measured points.

3.	 Now add a watch window using View>Watch Window>Add Point 
to>Objects. Select the first laser tracker and then select the 
plane. Accept the default projection options.
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Tutorial Index:

Alignment 

Weighting in Relationship Optimizations

USMN 

Minimizing Relationships
	■ Skill Level. Intermediate

	■ Description. In this tutorial, we will explore relationship mini-
mization, an extremely useful capability used for alignment, 
assembly, and a host of other applications. We’ll use relation-
ships to locate our measurements relative to a CAD part, using 
a series of different situations.

	■ Areas Covered. Moving objects by minimizing relationships, 
local minima, Standard vs. Direct Search optimization, and re-
lationship weighting.

	■ Time to Complete. Approximately 25 minutes.

Note:� This tutorial requires 
SA Ultimate or greater.

The following tutorials are designed to guide you through various topics 
in SA and get you up and running as quickly as possible. They are specific 
topic based step by step guides to accomplishing specific tasks but as a 
whole they should help directly though the software and help to under-
stand the workflow and approach to operations within SA. 

For greater depth and theory consider one of our courses and contact 
training@kinematics.com for more details.

Advanced 
Alignments



164

SPATIALANALYZER USER MANUAL

Relationship Minimization

One of the great advantages of relationships is their ability to define 
constraints and alignment parameters. In traditional metrology soft-
ware, degree-of-freedom constraints for alignments are usually ex-
plicitly specified. For example, if a pin is constraining an assembly, 
one might explicitly lock a degree of freedom along the radial direc-
tions of the pin, so that the pin only allows travel along its length.

Relationships, by their very nature, automatically take care of con-
straints when they are created. Different geometric setups will result 
in different constraints. For example, if a relationship is set up be-
tween a set of points and a plane, the plane will by its very nature 
constrain distance from the plane, but will allow the points to rotate 
in the plane’s surface. As a result, a plane introduces a positional con-
straint along its normal, and rotational constraints in the plane of the 
plane. The ability to set up these constraints “naturally”, without ex-
plicitly defining further constraint parameters, is one of the signifi-
cant advantages of relationships over other alignment methods.

1.	 We’ll start by opening a tutorial file included with your instal-
lation of SA. In SA, choose Help>Open Sample SA Files. Choose the 
Relationships.xit file.

2.	 In this file, five relationships have been set up for you. Three 
of these relationships are between the CAD model and the 
measurements of specific features of interest. The last two (Ta-
bletop and Centerline) relate measurements to a table surface 
and center plane, respectively. To see how these relationships 
were created, see the Creating Relationships tutorial. Notice 
also how the measurements have not yet been aligned to the 
CAD model. That’s one of the tasks we’ll be accomplishing in 
this tutorial.

3.	 Let’s align our measured data to the CAD model. From the 
menus, choose Relationships>Move Objects by Minimizing Relation-
ships. In this case, we only want to move the instrument (and 
by association the targets measured by that instrument). So, 
when prompted for the Objects to Move, just press Enter. 
When prompted for the Instruments to Move, double-click 
the instrument and press Enter. The Minimize Relationships 
dialog will appear (Figure 10-1).
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Figure 10-1.  The Minimize 
Relationships dialog.

4.	 The process of relationship minimization finds the optimum 
position of the specified moving objects and instruments that 
results in the smallest RMS error. Let’s first take a look at how 
our measured points fit to the CAD model, without including 
our tabletop or centerline in the solution. Uncheck the Cen-
terline and Tabletop relationships to exclude them from the 
minimization process (Figure 10-2), then click the Run Optimiza-
tion button. This is the “standard” method of minimizing rela-
tionships.

Figure 10-2.  Excluding the 
Centerline and Tabletop relationships 
from the solution.

5.	 The instrument’s position and orientation will be adjusted to 
arrive at a minimum error, which represents the ideal fit. Note 
that as the solution progresses, the RMS Objective value decreases 
toward zero (Figure 10-3).

Figure 10-3.  The objective pro-
gresses toward zero as the relationship 
solves.

6.	 The resulting absolute maximum and RMS errors are also dis-
played for each individual relationship in the Minimize Rela-
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tionships window. The results look good, but we didn’t get a 
good idea of what was going on. Let’s move the instrument 
back up in Z. Click the Move Manually button, and in the Trans-
form dialog, type 5 into the Z value and press Enter. Close 
the Transform dialog. Let’s also choose an option so we can 
actually see the intermediate positions as the relationship is 
being solved. In the Minimize Relationships dialog, check the 
Show Steps checkbox (Figure 10-4).

Figure 10-4.  Turning on the Show 
Steps option.

7.	 Move the Minimize Relationships window to the side of the 
screen so that you can see the graphical view, then again click 
the Run Optimization button. Watch as SA solves the equations to 
minimize the error.

Local Minima

Under the hood, relationships are projecting measured points to the 
CAD surfaces and calculating the resulting deviations.  If the mea-
sured points are too far from the CAD surfaces, or if the points are 
flipped from their true orientation, then depending on the geometry 
of the setup and the surfaces, it is possible for the solution to reach a 
local minimum, and stop prematurely.

1.	 Again, click the Move Manually button.  In the Transform dialog, 
enter 180 for Ry and -10 for Z. Notice that the measured data 
is now flipped upside-down relative to the CAD model. Close 
the Transform dialog, and again click the Run Optimization button.

2.	 The relationship solves and stops. Click the Apply Transforma-
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tion button, and take a look at the graphical view. Clearly our 
points are flipped upside-down relative to the CAD model, 
and we have a large RMS error. What’s going on here? What’s 
happening is that the solution is getting caught in a local min-
imum. When minimizing relationships, you always want your 
measured points to have a “clean approach” to the geometry 
that you’re relating to. This means that there shouldn’t be any 
large rotations required that cause the relative orientation be-
tween the CAD and the measured data to “flip”. Depending on 
the geometry of the setup, the solution could get caught up 
in the wrong minimum, as seen here.

3.	 Let’s fix our local minimum problem so we can ensure that 
the relationship solves to the correct position. Click the Views 
button to go to the Side View (Figure 10-5).

Figure 10-5.  Selecting the 
predefined Side view.

4.	 From the menu, select Instrument>Drag Graphically. Hold down 
the right mouse button to rotate the instrument approxi-
mately 180 degrees (Figure 10-6).

Figure 10-6.  The instrument has 
been rotated about 180 degrees out.

5.	 Again, choose Relationships>Move Objects by Minimizing Relation-
ships. As before, don’t move any objects, but move the instru-
ment. Ensure that the Centerline and Tabletop relationships 
are still deselected. Click the Run Optimization button. You’ll no-
tice that, after a few seconds, the solution comes to an abrupt 
and premature end--the points remain in their original posi-
tions. Because the initial condition for the solution is so far 
from the CAD model, a local minimum is being encountered.

6.	 Instead, click the Run Direct Search Optimization button. Direct Search 
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Optimization is a more “brute-force” method of finding a 
minimum. It involves exploring the solution space more thor-
oughly to find a more optimized orientation, then moving to 
that intermediate position and checking again. This method 
is slower, and requires more time to solve (sometimes, signifi-
cantly more time). Depending on the setup, it can also end up 
with a “flipped” result. However, it is less likely to get caught in 
a local minimum. After a few seconds of calculating--once the 
Objective value is under about 0.8”--click the Cancel button.

7.	 Notice that, rather than returning to the original position and 
orientation, the instrument and points stopped in their cur-
rent position. This is a helpful behavior, because we can now 
switch to the traditional optimization method to close up the 
fit the rest of the way. Click the Run Optimization button, and the 
solution should be reached relatively quickly. When finished, 
click the Apply Transformation button. If you notice that your solu-
tion has solved to the incorrect orientation, move and rotate 
the instrument for a better starting condition and try again.

8.	 What is the lesson from all of this? The fact is, you’ll avoid all 
of these issues with reaching local minima if you start with a 
good initial condition. As long as you manually orient the in-
strument so that the points have a relatively clean approach 
to the surface, and as long as they aren’t too far away from 
the surface, the solution can be approached with no trouble. 
Many people will do a rough orientation using Quick Align, then 
fit with more data using relationships. In a situation like that, 
you won’t encounter problems with local minima.

Incorporating the Tabletop and Centerline

1.	 Suppose that we now wish to incorporate the measurements 
of the tabletop to our fit. If we assume that the bottom sur-
face is flat, and that the tabletop is flat, then our measured 
tabletop points represent the bottom surface of the CAD part. 
Press Ctrl+Tab to reselect the last command, which should 
be the Move Objects by Minimizing Relationships command. As be-
fore, pick to move just the instrument.

2.	 This time, ensure that the Tabletop relationship is also se-
lected, then click Run Optimization again. Our RMS error has in-
creased from 0.0013” to 0.0022”, but we’ve now allowed our 
measurements of the tabletop to influence the solution. Since 
the Tabletop Plane plane is facing directly along the Z axis, the 
relationship is only affecting the final solution’s Rx, Ry, and Z 
results. X, Y, and Rz are not affected due to the geometry of 
the plane. (Rotating about Z or translating along X or Y will 
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not affect the distance of the Plane points from the Tabletop 
Plane plane. Click the Apply Transformation button to accept the 
results.

3.	 Click the Views button in the toolbar to select the Top view, 
then zoom in on the CAD model and measured points. In the 
tree, right-click the Point Groups category header and choose 
Hide All from the context menu. Then, right-click the Centerline 
point group and choose Show from the menu (Figure 10-7).

Figure 10-7.  Showing the Center-
line point group.

4.	 We haven’t yet incorporated our Centerline relationship into 
the solution. Let’s say, for sake of this tutorial, that it is very im-
portant to us that the measured centerline points are aligned 
well to the centerline plane. We still want the measured points 
of the CAD surface to influence our fit, but we consider the 
centerline measurements to be much more important. We 
can weight the Centerline relationship to have a much stron-
ger influence in the overall solution.

5.	 Press Ctrl+Shift+TAB and choose the Relationships>Move 
Objects by Minimizing Relationships command from the list, and 
specify to move just the instrument. In the Minimize Relation-
ships dialog, ensure that all five relationships are checked so 
that we incorporate them all into the minimization process.

6.	 Single-click the row with the Centerline relationship so that it 
is selected. Then, single-click the Weight column. Give the Cen-
terline relationship a weight of 100 (Figure 10-8). This is equiv-
alent to saying that we consider errors from the points in the 
Centerline relationship to be 100 times more important than 
errors from the points in the other relationships.

Figure 10-8.  Setting the weight of 
the Centerline relationship to 100.
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7.	 Click the Run Optimization button.  It may be difficult to see, but 
the solution has been adjusted to try to minimize the center-
line errors with more effort than the other relationships, due 
to the higher weight assigned to the Centerline relationship. 
Notice that the RMS errors have jumped way up. As you can 
see, the points measured on the centerline were not mea-
sured carefully. Uncheck the Centerline relationship to again 
remove it from the minimization process.

8.	 This time, let’s give the Tabletop relationship a little less weight, 
since it’s not a direct measurement of the bottom surface of 
the part. Give it a weight of 0.5, and click the Run Optimization 
button. Now, the tabletop is still incorporated into the solu-
tion, but it is not considered to be as important.

Conclusion

We’ve seen here that it is important to give relationships a good 
“initial condition” to ensure that relationship minimization does not 
get caught up in a local minimum. We’ve also seen how relationship 
weighting can be used to assign more or less influence to different 
measured features when minimizing.



171

CHAPTER 10 ■ Advanced Alignments

Basic USMN
	■ Skill Level. Intermediate

	■ Description. In this tutorial, we will cover the basic process for 
performing a USMN network.

	■ Areas Covered. Unified Spatial Metrology Network.

	■ Time to Complete. Approximately 15 minutes.

USMN Sample File

1.	 We’ll start by opening a tutorial file included with your instal-
lation of SA. In SA, choose Help>Open Sample SA Files.   Choose 
the USMN.xit file. This file contains four instruments with 
common measurements (Figure 10-9). The goal is to bring all 
of these instruments into one common network and create 
a point group that represent the network as a whole. Tradi-
tional methods use a best-fit approach, but unfortunately er-
ror stack-up affects the instrument positions greatly. USMN 
uses instrument uncertainty and advanced optimization al-
gorithms to simultaneously solve for all instrument positions, 
ultimately removing the error stack up and increasing the 
accuracy of the instrument network. When more than two 
instrument locations are present, it is recommended to use 
USMN.

Figure 10-9.  Prior to the USMN 
bundle.

2.	 To start the USMN process, navigate to Analysis>Coordinate 
Uncertainty>Unified Spatial Metrology Network. You will be prompt-
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ed to select the instruments for the USMN network. Select 
the four instruments in the job. The USMN interface will be 
displayed (Figure 10-10), and you will have the controls and 
tools to create and analyze the measurement network. The 
next few steps will walk through this process.

Figure 10-10.  The USMN dialog.

3.	 Press the Best-Fit then Solve button. The instrument stations will 
be located to one another first by a best-fit. Their positions 
will then be optimized using an uncertainty model for each 
instrument.

4.	 Now note the Max Error and Ranking of each point (Figure 10-11). 
The ranking is an indication of the uncertainty of the point 
error in the network. Typically, points over 100% ranking are 
removed from the solution.

Figure 10-11.  Point details, 
including Max Error and Ranking.

5.	 Press the Trim Outliers button to remove points that exceed a 
specified ranking (Figure 10-12). In our case, we will remove 
any points over 100%.
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Figure 10-12.  Trimming outliers.

6.	 Now press the Solve button to resolve the network for the re-
maining points. Now note the Max error and Ranking values (Fig-
ure 10-14). The rule of thumb is to only trim outliers one time, 
so we will leave point 10 with its new ranking of 110%.

Figure 10-13.  New ranking values 
after outliers have been trimmed.

7.	 Once the outliers have been trimmed, compute the uncer-
tainties of the network by pressing the Begin button under the 
Uncertainty Field Analysis section. Once completed the uncertainties 
can now be reviewed (Figure 10-14).
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Figure 10-14.  Calculating com-
posite point uncertainties.

8.	 Now apply the results of the USMN. Each of the four instru-
ments should now be aligned (Figure 10-15).

Figure 10-15.  After the USMN 
bundle.

9.	  A USMN Composite point group will be created. This point 
group will represent the optimized locations of the common 
points and represents the instrument network as a whole. Fig-
ure 10-16 is a close up look at a composite point versus the 
measured points.
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Figure 10-16.  The position of the 
USMN composite point relative to the 
measured points.

Conclusion

We have learned how to bring multiple instruments into one network 
easily and with more accuracy than best-fit methods alone. For more 
information on USMN, see the USMN section.
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